Como utilizar ficheiros "package"

Uso há bastante tempo. Uma nota com este método não é possível fazer reload nas automações ou scrips sem reiniciar o Ha. Ou seja qualquer alteração que se faça é necessário reiniciar o home assistant.
Comecei a usar os packages, por ser muito mais fácil organizar os ficheiros.
Eu organizo por área de casa…ou seja sala.yaml,cozinha.yaml etc sabendo assim onde tenho que alterar ou adicionar algo que queira.
RECOMENDO

1 Like

No meu caso as automações não funcionam, tive de colocar as automaçoes no ficheiro automations.yaml .

A configuração que uso é a seguinte :

  - alias: Desligar Tomada
    trigger:
      platform: time
      at: '19:45:00'
    action:
      - service: switch.turn_off
        entity_id: switch.Tomada
      
# 
  - alias: Desligar Monitor
    trigger:
      platform: time
      at: '00:45:00'
    action:
      - service: switch.turn_off
        entity_id: switch.monitor

  - alias: Desligar TV
    trigger:
      platform: time
      at: '21:30'
    action:
      - service: switch.turn_off
        entity_id: switch.Tv
      
#estore hall
  - alias: Abrir estores as 8
trigger:
  platform: time
  at: '15:36'
action:
  service: cover.open_cover
  data:
    entity_id: cover.persianahall
  

  - alias: fechar estores as 22
trigger:
  platform: time
  at: '22:00'
action:
  service: cover.close_cover
  data:
    entity_id: cover.persianahall

*Nota - A automação dos estores não funciona.

Desculpem esta pergunta básica, mas onde é que criaram a pasta Package? Foi na root ou dentro da pasta config?

Obrigado

@Joao_Ferreira 📑 Como utilizar ficheiros "package"

Bom dia @RodolfoVieira.
Antes de ter feito a pergunta já tinha percorrido o Tutorial que me enviaste, juntamente com o Como integrar o aspirador da Xiaomi no HA.
Acontece que ao criar o ficheiro xiaomi_vacuum.yaml e colocá-lo dentro da pasta “packages” não me aparece nada, daí a minha pergunta (que no tut não especifica bem onde é para criar essa pasta).

No configuration.yaml também coloquei

  packages: !include_dir_named packages/

Obrigado

A pasta packages é criada dentro da pasta /config casos uses o Hassio.

Não aparece nada mas há algum erro no log do HA?

Julgo que já esteja a funcionar. Era uma questão de nome do ficheiro…estava package (no singular)…Ele ao estar a apanhar as entities, significava que estava a apanhar o ficheiro.

Obrigado pela a ajuda

Boa noite…

Já tentei criar ficheiros YAML, mas dá sempre erro…

Por exemplo:

Tenho a função do speed test no ficheiro configuration.yaml…como faço para o retirar deste ficheiro e criar um só para o speed test…

Obrigado

Já chamaste dentro do teu configuration.yaml o `packages: !include_dir_named packages ?

Se sim, agora dentro da tua pasta /config, e supondo que já tenhas a pasta packages criada,
bastaria criares um novo ficheiro dentro dessa pasta exemplo : speedteste.yaml e colarás o que te mostro abaixo.

sensor:
  - platform: speedtest
    monitored_conditions:
      - ping
      - download
      - upload

Boa noite…
um muito obrigado,
ja está a funcionar.
faltava-me a palavra sensor: no ficheiro…

As voltas que eu já dei :slight_smile:
Obrigado e boa noite

até um proxima duvida :smile:

2 Likes

Boa tarde,

Estou a mudar o meu HA para uma VM e já que estou a instalar de novo queria organizar as coisas de maneira diferente, e isto seria muito bom :slight_smile:

A minha pergunta é a seguinte…queria dividir a configuração por divisões da casa, mas em algumas divisões tenho cover
Não dá mesmo para colocar entities ‘cover’ no package ?

Obrigado

Bloco de Citação

1 Like

De inicio (quando o tutorial dos packages foi escrito) havia algumas restrições e nem todas as plataformas eram suportadas mas a situação evoluiu e o cover já é suportado.

1 Like

Estou tentando usar o packages para simplificar meus códigos, seguindo o passo a passo. Mas quando mando validar a configuração dá esse erro abaixo:

Component error: packages - Integration ‘packages’ not found.

Mesmo eu tendo criado a pasta desta forma: /config/packages e incluso na configuration.yaml a linha: packages: !include_dir_named packages/

homeassistant:
  packages: !include_dir_named packages

Pelo que percebi tens tudo ok… Só colocas-te mal no configuration.yaml… tem de ser como em cima.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade