Problemas de ligação ao MQTT (Broadlink com Tasmota)

Viva,

Já recebi o meu bridge com tasmota.
No entretanto já consegui tambem flashar em tasmota :slight_smile:

A questão é que em tasmota não fuciona no Broadlink (pelo menos eu não sei)

Então tentei no home assist (primeira vez na vida que vejo isto).

Fiz o setting do MQTT no bridge

Depois no home assist (raspberry pi3 emprestado) vejo o seguinte log:

1560927204: Saving in-memory database to /data/mosquitto.db.

1560927299: New connection from 192.168.1.98 on port 1883.

1560927299: Socket error on client <unknown>, disconnecting.

no config do Mosquitto broker tenho isto:

{
  "logins": [],
  "anonymous": true,
  "quiet_logs": true,
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

alguem consegue dar aqui um “empurrão” (já segui os passos de 1 a 6 aqui no forum, mas mesmo assim ainda sou um embrião)

@helcpha quando publicares código deves sublinhar o texto que queres transformar em código e clicar no icone </>. Deverá existir um espaço antes e outro depois do bloco de código para que funcione correctamente. O código em Yaml é muito sensível aos espaçamentos e sem o código devidamente formatado não te poderemos ajudar.

Além disso, existem regras no fórum que devem ser cumpridas e que podes ler nos nossos Termos do Serviço/Regras e na FAQ.

Vê um exemplo:

já corrigi. ficou bem assim?

Por motivos de segurança deves SEMPRE utilizar um user e pass e colocar o anonymous a false, assim:

{
  "logins": [
    {
      "username": "xxxxxx",
      "password": "xxxxxx"
    }
  ],
  "anonymous": false,
  "quiet_logs": true,
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

Utiliza sempre passwords fortes. Depois vais ao Broadlink e configuras o username e password na parte do MQTT. O Tasmota vai reiniciar e depois disso vê o log.

Publica aqui qual o teu sistema (hassio, hass), a versão do Tasmota, o log do MQTT e da consola do Tasmota.

para configuara o username e password referias ao Hass.io no Pi3 certo?
Ou é mesmo possivel o fazer no Broadlink?
Fiquei confuso.

O tasmota que tenho no bridge e no basic é o 6.5
Quando falas em publicar o sistema referes ao Pi3 com Hass.io?

actualizei agora o Config como indicou.
Infelizmente o log mantem-se:

1560982074: New connection from 192.168.1.98 on port 1883. 1560982074: Socket error on client &lt;unknown&gt;, disconnecting.

@helcpha possivelmente poderá ser um problema com o addon do mosquito , tens a versão 4.3 correcto?

As configurações são para colocar no addon. Sim, era para saber se era Hassio ou não. Faltam os logs do addon e a consola do Tasmota quando se tenta ligar.

Tal como o @RodolfoVieira referiu, verifica qual a versão do teu addon.

o meu addon mosquito é o 4.3.
estou com o hassio.

logs addon:

1560981854: New connection from 192.168.1.98 on port 1883. 1560981854: Socket error on client &lt;unknown&gt;, disconnecting. 1560981865: New connection from 192.168.1.98 on port 1883. 1560981865: Socket error on client &lt;unknown&gt;, disconnecting. 1560981876: New connection from 192.168.1.98 on port 1883. 1560981876: Socket error on client &lt;unknown&gt;, disconnecting. 1560981887: New connection from 192.168.1.98 on port 1883. 1560981887: Socket error on client &lt;unknown&gt;, disconnecting. 1560981898: New connection from 192.168.1.98 on port 1883. 1560981898: Socket error on client &lt;unknown&gt;, disconnecting. 1560981909: New connection from 192.168.1.98 on port 1883. 1560981909: Socket error on client &lt;unknown&gt;, disconnecting.

logs tasmota:

00:00:00 APP: Ajuste da velocidade para 19200
00:00:00 Projeto sonoff Sonoff Versão 6.5.0(release-sonoff)-2_3_0
00:00:00 WIF: Ligando ao AP1 ASUS em modo 11N como bridge-4110...
00:00:04 WIF: Ligado
00:00:04 HTP: Servidor WEB ativo em bridge-4110 com o endereço IP 192.168.1.98
23:50:48 MQT: A ligar...
23:50:54 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec
23:51:05 MQT: A ligar...
23:51:11 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec
23:51:22 MQT: A ligar...
23:51:28 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec
23:51:39 MQT: A ligar...
23:51:45 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec
23:51:56 MQT: A ligar...
23:52:02 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec
23:52:13 MQT: A ligar...
23:52:19 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec
23:52:30 MQT: A ligar...
23:52:36 MQT: A ligação falhou ao 192.168.1.145:1883, rc -2. Tentativa em 10 sec

Um dos problemas que poderás ter (ou vir a ter) é de usares o Tasmota em português. Experimenta utilizar a versão “normal” do Tasmota para ver se os erros se mantêm.

Podes fazer a alteração colocando o endereço http://thehackbox.org/tasmota/release/sonoff.bin

Depois diz se resolveu.

bom dia Malta,

já flashei com o tasmota sugerido pelo Jorge.

infelizmente continua o erro, mas surge agora este:

1561019799: New connection from 192.168.1.98 on port 1883. [ERROR] Auth error with casa 1561019802: Socket error on client &lt;unknown&gt;, disconnecting. 1561019814: New connection from 192.168.1.98 on port 1883. [ERROR] Auth error with casa 1561019816: Socket error on client &lt;unknown&gt;, disconnecting.

será necessário mais algum setting alem de colocar o broker?
segui o passo a passo de 1 a 6 daqui do fórum, mas a inexperiência pode provocar falhas “fatais” :wink:

A post was split to a new topic: Problemas a flashar e configurar Sonoff Basic

Agora tens um erro de autenticação, o que quer dizer que ou não preencheste os campos username e password no Tasmota ou que esses estão errados e não batem certos com o que definiste no addon do MQTT.

pois… também pensei o mesmo!
olha o que tenho.

{
  "logins": [
    {
      "username": "casa",
      "password": "12345678"
    }
  ],
  "anonymous": false,
  "quiet_logs": true,
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

sei que não deveria de mostrar dados pessoais.
mas tudo que ai está é de teste, pois nada ainda funciona.
estou na fase de aprendizagem!!!

E por acaso no log do addon do MQTT não tens lá um erro quando arranca a dizer que a tua password está numa lista de passwords que não podem ser utilizadas?

Se não viste esse erro faz restart ao addon e vê se não aparece… Seja como for experimenta com uma password “normal”.

@helcpha pelo erro parece-me ser um problema conhecido do addon mqtt que em alguns casos, teima em dar erros de socket. Isso resolve-se colocando uma versao anterior do addon do mosquitto.
Passa pelo discord para eu te dizer como fazer.

Boas malta, tive a audacia de fazer o que se deve fazer nestes casos…
desisnstalei o broker e voltei a instalar e…

[INFO] found DVES_USER on local database 1561042040: New client connected from 192.168.1.98 as bridge_casa_29 (c1, k10, u'DVES_USER'). 1561042104: New connection from 172.30.32.1 on port 1883. [WARN] Not found homeassistant on local database 1561042105: Socket error on client &lt;unknown&gt;, disconnecting.

parece que ligou, mas empancou noutro lado

espero nao estar incomodar muito.
mas teem ajudado bastante.
já estava para desistir disto do hassio, pi3 e tasmota

obrigado pelas ajudas :wink:

Tens de ver o que é que está no IP 172.30.32.1 (pelo endereço é um addon do Hassio) e que está a tentar utilizar o username homeassistant.

no desespero… formatei o cartao e comecei tudo de novo!

depois de configurado no pouco que aprendia fazer… obtive o seguinte:

[INFO] found homeassistant on local database
1561068860: New client connected from 172.30.32.1 as f10efe7c-6c9c-4980-9688-a714bd9cbcd1 (c1, k60, u'homeassistant').
1561068860: Client f10efe7c-6c9c-4980-9688-a714bd9cbcd1 disconnected.
1561068860: New connection from 172.30.32.1 on port 1883.
[INFO] found homeassistant on local database
1561068861: New client connected from 172.30.32.1 as fecb0598-b040-423d-a8e4-5d244fd08ea4 (c1, k60, u'homeassistant').

agora falta interagir com o bridge. agora como? vou explorar mais no forum!

para configurar o sonoff bridge segui este post:

de facto ajuda muito.
Pretendo que o bridge receba os codigos dos sensores PIR e janela.
Aquando um disparo destes sensores, gostaria de receber um alerta na app do telemovel.

alguém sabe orientar como fazer isso?


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade