TTS no Google Home Mini

Mudei a config. como indicaste aqui em cima @karma mas está igual. Se for direito ao componente media player dele e escrever lá texto para ele falar, ele fala. Mas se for via script, dá aquele erro de token e não fala comigo.

@marcopinheiro, experimenta actualizar o HA. Pois eu estou com a versão 0.83.1. E Podes experimentar com outro tts por exemplo também.

Exprimentem a polly , vão gostar de certeza.
tenho um video em que explico como se faz:

Karma, update ao HA e bingo!! Obrigado por tudo!

1 Like

Pessoal meu google home mini parou de responder em português isso aconteceu com mais alguém?

Att,

Comigo também já aconteceu. Deixei de ter a língua portugês br na opção de menu já há bastante tempo

2 posts were split to a new topic: TTS no raspicast

Boa noite meu caros,
Encontrei este post, e não querendo abrir outro e na sequência de ter tentado fazer uma automação com voz e ter percebido que não consigo, a semelhança do que acontecia com o @marcopinheiro, não consigo fazer broadcast ao texto que coloco no Google Mini.
GMini

Configurações:

http:
  base_url: !secret http_base_url
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

tts:
  - platform: google_translate
    service_name: google_say

Agradeço desde já a ajuda.

no meu tenho configurado assim

# Text to speech
tts:
  - platform: google_translate
    language: pt

Olá @nunocampos105, muito obrigado pela resposta mas dessa forma também não funcionou.
O Google até dá sinal mas continua sem dizer nada, seja em PT ou em UK.

Eu no meu caso para o tts funcionar, acho que na altura foi adicionar o endereço duckdns no “base_url”

base_url: o_teu_endereço.duckdns.org:8123

Olá @Karma, obrigado também mas já tenho esse endereço adicionado :wink:

E como é que tens o google assistant configurado no yaml?

O Goggle assistant está via cloud via “Nabu Casa Account”, acho que era isso que querias saber, alem disso não tenho mais configurações.

Boa tarde, só para informar que já tenho a situação resolvida. Obrigado pelas ajudas.
Solução:
Como tenho o acesso via Nabu Casa, tive de desabilitar/comentar a conf de HTTP.

http:
  base_url: !secret http_base_url
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

Não deves comentar todo o bloco do http:, basta comentar a parte dos certificados. Existem vários addons e componentes que utilizam a entrada base_url.

Bom dia @j_assuncao, se eu descomentar o TTS não funciona. Tem de estar tudo comentado para funcionar.
Sabes me dizer que addons ou componentes que podem não funcionar, para validar do meu lado se funcionam.
Obrigado

Isso não deveria acontecer porque o próprio HA usa o base_url.

Quanto aos addon, tirando o DuckDNS e o Spotify não te sei dizer mais de cabeça. Faz uma pesquisa no Google pelos que usas para obteres mais informação.

Obrigado @j_assuncao, entretanto vou ficar atento se alguns do meus componentes e automações falham .

Viva,

Estou com uma dúvida, o TTS está a funcionar numa automação, mas com o código abaixo, estava à espera que a mensagem fosse diferente, ou seja, fosse “A janela da sala está aberta”, mas o que ouço é " A janela {{ trigger.to_state.attributes.friendly_name }} está aberta"

O que estou a fazer de errado?

Obg

  - data:
      language: pt
      message: 'A janela {{ trigger.to_state.attributes.friendly_name }} está aberta'
    entity_id: media_player.sala_de_estar
    service: tts.google_translate_say

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade