Sensor de som no sonoff

Boas.
Será que alguem já conseguiu ou tentou ligar um sensor de som ao sonoff?
Ou seja a ideia seria ligar o sensor de som ao sonoff e com um bater de palmas a luz acendia e vice-versa.

Eu nao estou a conseguir uma ajuda era benvinda.

Cumprimentos

“O que tu queres sei eu!”

https://m.pt.aliexpress.com/item/32958241632.html?pid=808_0000_0131&spm=a2g0n.search-amp.list.32958241632&aff_trace_key=&aff_platform=msite&m_page_id=PAGE_VIEW_IDCLIENT_ID(aefeMsite)NAV_TIMING(navigationStart)

Que tipo de sensor estás a usar?

Nao é nada disso que eu quero.
Eu liguei o sensor de som ao gpio14 já afinei a sensibilidade mas queria que ao bater palmas(ou outro barulho qualquer) o relé do sonoff acionasse.
o sensor que estou a usar é este “KY-038”

Bem vindo ao fórum da CPHA @avense, não esqueças de ler nos nossos Termos do Serviço/Regras e a FAQ.

Para isso que queres tens de ter um firmware compatível, o que estás a usar no Sonoff?

1 Like

boas.
Tenho o tasmota no sonoff.
Existe algum firmware mais especifico para o efeito?
Cumprimentos

O Tasmota é excelente para isso. Que configurações estás a utilizar para configurar o Tasmota?

A unica coisa que fiz foi colocar os dados do mqtt e colocar o switch1 no gpio14 e nao sei fazer mais nada loool

Mostra um screenshot da página de configurações do modulo.

ok.
Aqui está.

Hummm… e mostra lá as ligações no Sonoff.

tens o modulo ligado na saída digital ligado a um pino do basic? mete lá uma foto dessas ligações

A ligaçai está assim:
No sonoff o pin logo a seguir ao botao liguei-o ao + do sensor que é o terceiro a contar da esquerda para a direita da foto k enviei.
A seguir o terceiro pin do sonoff liguei ao r5 do sensor.
E o ultimo pin do sonoff liguei ao gnd do sensor ou seja o segundo a contar da esquerda da foto k coloquei.

Dá para entender?

É melhor com uma foto, só para tirar as duvidas.

Esse sensor funciona a 5v… será que não estás a tirar o suficiente para alimentar?

Adicionalmente, tens os cabos ligados ao D0 ou ao A0?

Mas ele funciona bem pk eu faço o ruído e o sensor acende o led e apaga conforme esse ruído.

aqui vao as fotos vamos ver se dá para esclarecer.

http://5.135.45.160/img/20190828_152812.jpg

A foto não aparece, é só arrastar para dentro da caixa de texto.

http://5.135.45.160/img/20190828_152902.jpg

Aparentemente está bem ligado. Que informação tens na consola do tasmota quando a luz acende?

1 Like

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade