Rádios com informação das músicas e álbuns

Boas Bruno;
Agradeço o otimo trabalho efectuado mas ainda não consegui instalar.
Instalei a poucos dias o Home estive fazendo as configuraçoes até a “e criamos também uma pasta downloads. Apos terem feito isto podem reiniciar o vosso Home Assistant.”, não sei onde colocar as Lovelace, segundo me parece falta-me colocar um leitor de media.
Agradeço a atenção dispensada.
cmp Julio

Boa tarde Júlio, bem vindo a esta fantástica comunidade. Esqueci-me de referir no tutorial que todo este tutorial está preparado para o sistema de packages. A pasta www tem de ser criada dentro da pasta config. As configurações no lovelace é só criar um card manual e meter lá o código disponibilizado.

Boa Tarde Bruno;

Agradeço a atenção, mas tenho ter um equipamento da Google ou Alexa?
Tenho uma Alexa, dentro da pasta www está vazia o que coloco la dentro?
No card manual tenho varios erros como por exemplo “mini-media-player.”

Antes de mais nada, aproveito para agradecer ao Bruno Melo e ao Pedro Miguel Fernandes pelo trabalho desenvolvido e pela partilha aqui no fórum.

Júlio,
Eu experimentei este tutorial com os meus Google Nest e funciona muito bem.
Deverás ter em atenção o seguinte:

  • O tutorial aqui colocado é para equipamentos “google”, através da integração automática Google Cast.
  • É necessário instalar também o Custom Component: Mini-Media-Player;
  • É necessário editar o ficheiro radio.yaml para colocares as “entity_id” corretas (as entidades referentes aos teus equipamentos. Poderás ver isso indo a Configuração → Integrações → Google Cast (x dispositivos);
  • No card manual que criares para ter o radio tens que colocar as “entity_id” corretas também (o Bruno deixou 4 exemplos no tutorial - cozinha, escritorio, sala, ambiente).
    As pastas a criar e respeticos ficheiros devem estar nas localizações corretas:
    – config\packages
    – config\python_scripts
    – config\www\downloads
    – config\www\radio_logo

Olá Federico;
Obrigado mas já não tenho o Google Nest em casa para testar, tenho que adquir um, tenho a Alexa já á algum tempo mas parece que e bem mais complicado.
cmp Julio

Júlio,
Para Alexa há aqui no fórum outro tópico do Pedro Miguel Fernandes para o mesmo objetivo:

1 Like

Boa tarde @maxcalavera .
Estou a seguir o teu tutorial e alterei apenas a entidade se acordo com o meu equipamento.
Está a dar-me um erro como mostra a imagem.
erro

O que achas que pode estar errado?

Verifica no ficheiro radio.yaml, na pasta “packages”, se não terás posto de forma errada o entity_id do teu speaker.

Obrigado @MarAE . Acabei por optar por esta versão.

Recentemente, apesar de o script conseguir ir buscar os dados aos “nowplaying.xml” e tudo ser visto no mode: edit, quando se põe a tocar nenhum dos dados surge:

Edit mode ex:

Playing mode:

@maxcalavera, ainda tens isso a funcionar sem problemas?

Sim. Ainda agora testei e está tudo a funcionar na perfeição…

Estranho; continuar a dar uma vista de olhos no code.

Nos cards também tens de mudar os media players para os teus… Já viste isso? Se precisares de algo estou pelo discord… :stuck_out_tongue_winking_eye::stuck_out_tongue_winking_eye:

Sim, alterei tudo, e estava a funcionar bem até há pouco.
Começo a suspeitar alguma alteração no mod-card ou layout-card, do HACS. Aquilo anda a ter atualizações diárias…

Vou continuar a tentar ver o que se está a passar, e caso não dê com o problema logo te vou chatear. :wink:

Acabei por encontrar o problema. Está resolvido.

1 Like

Marco, como é que resolveste? Qual era o problema?
Estou exactamente com o mesmo problema, no modo edit aparece o “now playing” no modo normal não…
Já tentei de tudo…
Se der para partilhares como resolveste era top…
Obrigado

Se encontraste uma solução para o teu problema, seria agradável partilha-la com o resto da Comunidade. O objetivo de uma Comunidade é partilhar conhecimento.

De certeza que se tivesses o mesmo problema que outro utilizador e ele cá viesse dizer “já descobri como resolver o problema” e não dissesse como o tinha feito, para tu também poderes resolver o problema, não irias gostar.

2 Likes

Viva, Nuno.
No meu caso tratou-se de algo mais perto de um typo que outra coisa, no file: radio.yaml

Pelo sim, pelo não, verifica com o File Editor/Notepad++ se de facto fizeste bem as mudanças das entity_id, do original para as tuas.
Usa os termos originais, se não forem os mesmos que estás a usar: cozinha, quarto, sala, escritorio, ambiente. Mas não faças a busca com “case sensitive”, pois pode escapar algo e isso afecta logo os templates - foi o que me aconteceu.

1 Like

Pois… eu já verifiquei quase linha a linha e não dou com o gato. Será que podias partilhar o teu radios.yaml para comparar?
Também deduzo que seja aí o problema.
Ou nisso ou onde estou a usar “content_id” e “media_title”…
Muito obrigado :pray:

Dá uma vista de olhos: https://pastebin.com/vbTEiiY4

As minhas entity_id:

  • bedroom_speaker
  • living_room_speaker
  • kitchen_speaker
  • home_group
1 Like

Copyright © 2017-2021. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade