Problemas com Sonoff

Olá!

Tenho vários sensores de temperatura e humidade Sonoff Zigbee ZB-TH01 espalhados pela casa e leio os seus valores para o HA usando Zigbee2MQTT. Até à uns dias atrás tudo fixe!

Acontece que de há uns dias um dos sensores deixou de mandar dados, suspeitei que fosse da pilha, então substituí e mandei emparelhar, mas agora, vendo a troca de mensagens usando o MQTT Explorer, quando clico no botão de emparelhar do sonoff apenas me aparece a mensagem de “announce” e nunca envia dados ou finaliza o emparelhamento.

Já tentei mil e uma coisas e não consigo fazer nada. Será que o sensor estará estragado ou alguém tem outro tipo de ideia em mente? Caso esteja estragado ele está na garantia, portanto posso sempre ativar a mesma.

O Zigbee2MQTT tem ativo a opção de “permit_join”

Obrigado!

Eu já não uso o z2m há mt tempo, mas já tentaste eliminar esse device, antes de o tentares emparelhar de novo?

No zigbee2MQTT não há propriamente maneira de “desemparelhar” equipamentos, pelo menos que eu saiba.

Adicionalmente, junto o output dos meus logs quando mando emparelhar o sensor:

Zigbee2MQTT:info  2021-01-06 19:11:54: MQTT publish: topic 'zigbee2mqtt/bridge/event', payload '{"data":{"friendly_name":"0x00124b002214f07c","ieee_address":"0x00124b002214f07c"},"type":"device_announce"}'
Zigbee2MQTT:info  2021-01-06 19:11:54: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"announce","meta":{"friendly_name":"0x00124b002214f07c"},"type":"device_announced"}'

Obrigado. Desconhecia isto!

No entanto, não resolveu :frowning: agora nem aparece na lista de devices reconhecidos.

1 Like

Nevermind…Mais algumas tentativas de remover, emparelhar e restart do serviço e ficou a funcionar :slight_smile:

Obrigado!

1 Like

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade