Lovelace- Horizontal e vertical Stack - Deixaram de funcionar desde 0.80

Sou novo no forum, mas já não sou novo no home assistant. Tinha o meu lovelace organizado com horizontal e vertical stacks, mas desde a actualização que deixaram de funcionar. Colocando todos os cards seguidos, funciona tudo na perfeiçao, colocando dentro de vertical e horizontal stacks, faz com que os cards deixem de funcionar. Alguem com o mesmo problema?

/n
Cannot read property ‘states’ of undefined

{
“id”: 65165166,
“type”: “horizontal-stack”,
“cards”: [
{
“type”: “sensor”,
“entity”: “sensor.temp_media_int”,
“name”: “Temperatura”,
“line_color”: “#3498db
},
{
“type”: “sensor”,
“entity”: “sensor.humi_media_int”,
“name”: “Humidade”,
“icon”: “mdi:waves”,
“line_color”: “#F59F00
}
]
}

E qual é a versão que tens agora?

Neste momento estou com:
0.81.0.dev0

Faz upgrade para a última e ve se resolve.
Segundo a dica do nosso moderador @tmarquespt nunca se deve actualizar para as versões acabadas em .0
pode trazer chatices.
Ainda assim caso não te resolva o problema com a última versão podes sempre retornar à 0.80.3

Mesmo na 0.80.1, penso que foi a partir dessa… Mas não consigo ter a certeza.

Não uso esse card para te puder ajudar, a minha solução seria actualizares para a última versão caso nao resolvesse como disse, voltares para uma versão anterior, e ires acompanhado no forum oficial se existe alguma mudança em relação a isso.

Na última versão já ele está… outra coisa estranha é nestes ultimos 2 dias, nao estou a conseguir reiniciar o home assistant, tenho de desligar da corrente e voltar a ligar. por vezes reposta o erro, outras vezes simpelsmente cliko em restart e nada acontece, nem erros sao mostrados…
Como tenho andado a desenvolver varias situações, se calhar vou optar por fzer um fresh install

@Nelson_Oliveira disseste acima que tas com a versão 0.81.0.dev0 mas a última é a 0.81.2 tás com essa?

Estranho… Ontem quando surgiu a actualizaçao clikei… supostamente deveria estar na ultima, até porque não me aparece nenhuma actualizaçao disponivel na tab “Hass.io

No hass.io ainda só está disponível a 0.81.1

como posso fazer para actualizar?

pip3 install homeassistant==0.81.2

@jpm o comando para hassio será:
hassio homeassistant update --options version=0.xx.x ( subsituir os x)

tem de ser pelo add-on SSH né? tenho de abrir a porta na router para conseguir aceder e nao estou em casa, mas vou tentar assim que chegar

sim tem de ser por ssh, ou então esperares e com sorte aparece a notificação.

Tentei por SSH, apos enviar o comando simplesmente me diz OK, entao aproveitei e reiniciei por SSH, fui a ver e continua igual…

O que continua igual ? a versão?

Sim, penso que vou ter de reinstalar deve ter havido algum problema com a actualização ontem

Mas quando fazes o downgrade, ou mesmo update isso demora sempre uns minutos. Não é imediato, esperaste cerca de 10 min?

Sim. Depois reiniciei… Nada…


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade