Integração Smart Socket Wi-Fi Xiaomi no HomeAssistent

Olá comunidade,
Em antes demais, agradecer a todos que contribuíem para que esta comunidade seja uma ajuda para todos que pretendem inicia na domotica/homeassistant.

Recentemente comprei uma tomada da Xiaomi “Smart socket” que pelo que li não possui zingbee.

Seguindo um tutorial consegui inserir já no homeassistant mas deparo me com um “problema” de estado, ou seja “indisponível”.

O que tenho inserido no config:

switch:

  • platform: xiaomi_miio
    name: Original Xiaomi Mi Smart WiFi Socket
    host: meu id da tomada
    token: TOKEN da tomada
    model: chuangmi.plug.m1

O meu estado é o que está na imagem.

Alguém que me possa indicar o que me falta ou que esteja mal inserido?

Obrigado.

Ja confirmaste o token?

No meu funciona

  • platform: xiaomi_miio
    name: Nome
    host: IP
    token: Token

Viva Bruno,

Julgo que sim, segui um tutorial para o fazer pela linha de comando.

Poderá ser isso?

o teu socket tem usb?

experimenta sem o modelo nas configuraçoes

@ccarlos07 e @blopes

Quando publicarem código devem sublinhar o texto que querem transformar em código e clicar no ícone </>. Deverá existir um espaço antes e outro depois do bloco de código para que funcione correctamente. O código em Yaml é muito sensível aos espaçamentos e sem o código devidamente formatado não poderemos ajudar.

Meu modelo é sem usb.
Retirando o modelo desaparece do home Assistant!

Já confirmei novamente o token e está correcto.

É igual ao meu…

Estranho porque nao tenho o modelo e identifica-o bem

Tenho o dispositivo ligado a um repetidor de sinal, poderá ser por essa razão?!

Só coloquei esse código no ficheiro conf, não é necessário mais nada certo?

Ainda hoje adicionei dois ao meu Home Assistant e também me apareceram indisponíveis pois tinha trocado os ips de um e de outro.

Dado que tens a certeza que o Token está correcto penso que o problema será o IP.

Problema resolvido!

Como suspeitava era por causa dos ips diferentes.
Tive que colocar o raspberry ligado ao router principal que repete para o resto da casa (repetidores)

Aconteceu algo que não sei como resolver, as notificações do Telegram deixaram de funcionar, qual o motivo, alguém quem me possa ajudar?

@ccarlos07 sendo outro assunto, abre por favor um novo tópico.

Peço desculpa Jorge, assim o farei.

Cumprimentos

1 Like

Este tópico foi automaticamente fechado 90 dias após a última resposta. Novas respostas não são permitidas.

Eu recentemente comprei duas tomadas inteligentes da xiaomi pela worten até agora ainda não descubri como conectalas ao home assistant, pois a unica maneira que eu encontro pede um token que as minhas tomadas não têm.

Podem ajudar??

Ass: Páscoa

Dá uma vista de olhos neste tópico:

1 Like

Eu descubri outra maneira que me deixa ficar até no servidor europeu, e me dá todas as informações que necessito;

Se quiserem que eu a partilhe avisem;

Podes partilhar sff.

Eu baixei esta versão do mi home ( https://android-apk.org/com.xiaomi.smarthome/43397902-mi-home/ ), depois iniciei a minha conta normalmente, escolhi o servidor europeu (pode ser qualquer um), fui ao meu gerenciador de ficheiros, e fui a armazenamento interno / smarthome / logs / plug_devicemaneger, e selecionei o arquivo txt com a data mais perta da atual. O mesmo tem todas as informações dos dispositivos ( muito baralhada ). Passei uma copia do arquivo para o pc, abri o bloco de notas, e procurei pelo nome dos meus dispositivos ( atravez de ctrl+f ). Perto do nome do dispositivo vais encontrar o token.

1 Like

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade