Gateway Xiaomi não reconhecido pelo home assistant

Boa noite.
Sou novo nestas andanças e não percebo nada . De automação e de tudo o que se fala aqui . Mas sou um entusiasta do assunto.
Já algum tempo que sigo o fórum . Depois de já ter alguns produtos Xiaomi dissidi instalar o hassio num Raspberry Pi3 .e isso foi fácil .
Logo no início após a instalação reparei que ele não reconheceu ninguém dispositivo da Xiaomi . Nem gatwey nem lâmpadas nem fora led nem sensores.
Foi ao YouTube ver o tuturial do fórum com integrar o mesmo . Segui os passos e consegui fazê-lo . Configuração válida . Mas continua sem reconhecer o gateway . Fiz o o tuturial do home assistant. Mas a mesma coisa configuração válida . Mas continua a dar erro não reconhece o gateway.
Alguém me poderá ajudar
Desde já obrigada

Boa tarde, supondo que tens o código certo no “configuration.yaml”

xiaomi_aqara:
  discovery_retry: 10
  gateways:
    - mac: AQUI_METES_O_MAC_DO_TEU_GATEWAY
      key: AQUI_METES_A_PASSWORD
      host: AQUI_METES_O_IP_DO_GATEWAY

Tens de ir à MiHome e aceder ao gateway depois “About” e carregas 9 vezes em “Plug-in version: 2.xxx” e ficas com a opção “Wireless communication protocol” visível, acedes e activas a mesma copiando a password e metes em “key” no “configuration.yaml”

Depois para as lâmpadas que estão no MiHome tens de instalar uma nova app “Yeelight” e configurar nessa app as lâmpadas, depois acedes a cada uma dela e activas a “local network”, elas vão deixar de funcionar no MiHome mas esta app até é melhor!

Agora reinicias o HA e pronto vai aparecer tudo no discovery

Isto foi uma explicação assim feita á pressa, se tiveres mais dúvidas avisa

Boas . Obrigada desde já pela resposta . Eu faço isso como disseste . E no fim aparece isto sempre

Qual é a tua versão do HA?

Acho que há uma versão da gateway que tem a porta 9898 fechada, o que impede a comunicação com o HA. Acho que podes verificar o estado da porta com um comando Nmap

O problema não vem daí, está a dar erro no próprio código do HA e não no acesso ao gateway

No meu caso tinha as portas fechadas, depois de horas e horas de pesquisas percebi que o gateway tem a porta 9898 fechada (confirmei via nmap), daí não comunicar com o HA.
Para resolver o problema é necessário:

1-Find specific screw bit like fork to open gateway case.
2-Find UART cable/board.
3-Solder 3 wires GND and RX / TX like here
4-Disconnect RX wire from UART module.
5-Dont connect Vcc (power) from UART to gateway.
6-Turn on gateway (220V).
7-Open putty application, connect to serial port (COM1-30) -select yours one0.
8-Wait for fully load of gateway, connect RX wire to UART.
9-You will see all messages of gateway.
10-Send command psm-set network.open_pf 3, send it few time in case it was spammed by gateway and it can be lost in msgs…
11-Check your param by command psm-get network.open_pf to be sure its OK.
12-Turn off gateway.
13-Turn it ON.
14-Check your port.

1 Like

Olá. Qual o router que tens?

Olá
Bom dia
É umTechnicolor TG784n v3

Home Assistant
0.91.2

Coloca aqui a configuração do gateway que tens no configuration.yaml. Não esqueças de formatar devidamente o código.

Como assim formatar o código devidamente

Já leste a nossa FAQ?

Obrigado a todos .
Já consegui que reconhece.
À muda antiga ou típico português. Nada como tirar da ficha e voltar a ligar .
Resolveu o problema

1 Like

Olá, decidi criar um tópico novo, já que o que existe é sobre o Aqara, o que poderá ser um pouco diferente…

Bom, segui o video e instruções do @RodolfoVieira a quem desde já agradeço. Para este Mi Control Hub, comecei por receber várias Notificações quando tentava reiniciar o servidor, basicamente a apresentar erros.

Encontrei este artigo: https://www.home-assistant.io/integrations/xiaomi_aqara onde indica um texto para o configuratio.yaml (hã…reparem como já pareço um profissional…) parecido mas de certa forma mais simplificado:
xiaomi_aqara:
discovery_retry: 5
gateways:
- key: xxxxxxxxxxxxxxxx

Usando este, reiniciou sem erros, mas quando arranca, aparece este:
image

Alguém me consegue ajudar?
Obrigado

@mqdias quando publicares código ou logs deves sublinhar o texto que queres transformar em código e clicar no icone </>. Deverá existir um espaço antes e outro depois do bloco de código para que funcione correctamente. O código em Yaml é muito sensível aos espaçamentos e sem o código devidamente formatado não te poderemos ajudar. E nos logs há pormenores que só devidamente formatados se conseguem ver.
Além disso, existem regras no fórum que devem ser cumpridas e que podes ler nos nossos Termos do Serviço/Regras e na FAQ .`

Vê um exemplo:

Ok @RodolfoVieira!
Quanto a este código, não estou em casa agora, mas tenho a certeza absoluta que antes tem uma linha de espaço, mas em baixo não. Portanto estará assim:

xiaomi_aqara:
discovery_retry: 5
gateways:
- key: xxxxxxxxxxxxxxxx

Quanto a essa questão dos LOGS, não sei se percebi bem…estás a sugerir que coloque aqui os logs?

Obrigado!

@mqdias se olhares nos posts mais acima podes ver que te falta na configuração o Mac e o Host

@RodolfoVieira o que eu tinha dito no post inicial foi que a minha primeira tentativa foi exactamente dessa forma como tinhas no tutorial, ou seja, com o MAC e HOST, mas colocando esses, permanentemente me dava uma notificação de erro aparentemente relacionado com o MAC. Este código que coloquei aqui, foi uma alternativa dada no site da Home Assistant…

Logo à noite voltarei a tentar dessa forma e colocando então uma linha de espaço abaixo, correcto?

Ok coloca de novo a configuração que tinhas e mostra depois como puseste,atenção, coloca aqui o código devidamente formatado.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade