Olá malta, tenho o HA (versão 0.96.5) a correr em Hass.io num pi3 b, tenho uma led strip da xiaomi adicionada e funciona sem problemas, no entanto adquiri uma segunda e não estou a conseguir que seja detectada nas entidades do HA, segue o código que tenho no configuration.yaml
yeelight:
devices:
192.168.1.3:
name: Leds TV
192.168.1.9:
name: Bancada
a que tem o ip 192.168.1.3 é reconhecida e funciona na boa, no entanto a segunda não… já lhe fiz reset várias vezes e não funcionou.
Será que alguém aqui já teve o mesmo problema e me consegue ajudar a encontrar uma solução?
realmente tenho aqui uns quandos erros no log, mas pelo que percebo são maioritariamente devido a device trackers…
Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
14:40 /usr/local/lib/python3.7/site-packages/telegram/ext/updater.py (ERROR) - message first occured at 5 de agosto de 2019 21:37 and shows up 1855 times
Login attempt or request with invalid authentication from 148.71.7.48
14:39 components/http/ban.py (WARNING)
Error doing job: SSL handshake failed
7:53 /usr/src/homeassistant/homeassistant/core.py (ERROR) - message first occured at 5:21 and shows up 4 times
[AS-MIBOX4[Cast]:44890] Failed to connect to service AS-MIBOX4[Cast]._googlecast._tcp.local., retrying in 5.0s
5 de agosto de 2019 23:59 /usr/local/lib/python3.7/site-packages/pychromecast/socket_client.py (ERROR)
[MIBOX4:8009] Failed to connect to service MIBOX4-987cffb1bf3cd0b619f44ed5ff609686._googlecast._tcp.local., retrying in 5.0s
5 de agosto de 2019 23:59 /usr/local/lib/python3.7/site-packages/pychromecast/socket_client.py (ERROR)
[AS-MIBOX4[Cast]:44890] Heartbeat timeout, resetting connection
5 de agosto de 2019 23:58 /usr/local/lib/python3.7/site-packages/pychromecast/socket_client.py (WARNING)
[MIBOX4:8009] Heartbeat timeout, resetting connection
5 de agosto de 2019 23:58 /usr/local/lib/python3.7/site-packages/pychromecast/socket_client.py (WARNING)
Unable to update device 192.168.1.3, Leds TV: Bulb closed the connection.
5 de agosto de 2019 23:58 components/yeelight/__init__.py (ERROR)
Error setting up platform legacy
5 de agosto de 2019 21:36 components/google_maps/device_tracker.py (ERROR)
Error setting up platform legacy
5 de agosto de 2019 21:36 components/device_tracker/setup.py (ERROR)
Failed to Login
5 de agosto de 2019 21:36 components/netgear/device_tracker.py (ERROR)
Get attached devices failed
5 de agosto de 2019 21:36 components/netgear/device_tracker.py (ERROR)
Error talking to API
5 de agosto de 2019 21:36 /usr/local/lib/python3.7/site-packages/pynetgear/__init__.py (ERROR) - message first occured at 5 de agosto de 2019 21:36 and shows up 2 times
Duplicate user_id 07607174ff8848b19854bb8d34fbdd31 detected for person de16f2beb0f74e878df3f11c601e8be4
5 de agosto de 2019 21:36 components/person/__init__.py (ERROR)
Loading IPMA via platform config is deprecated
5 de agosto de 2019 21:36 components/ipma/weather.py (WARNING)
Data in your config entry is going to override your configuration.yaml: {'broker': 'core-mosquitto', 'discovery': True, 'password': 'ahxah9wah2shie4CheewioQuoM2mohn5Vah1tosh8ahBiruk9Ou1kieWoe4Oseil', 'port': 1883, 'protocol': '3.1.1', 'username': 'homeassistant'}
5 de agosto de 2019 21:36 components/mqtt/__init__.py (WARNING)
Tens pelo menos um erro da yeelight. A configuração parece-me correcta mas questão é: o modelo que não aparece é suportado pelo componente?
Um outro problema que podes estar a ter é o componente discovery estar a atrapalhar a descoberta. Caso uses o discovery na tua configuração, adiciona o seguinte:
discovery:
ignore:
- yeelight
P.S.: O IPMA agora é configurado através das integrações no interface do HA Loading IPMA via platform config is deprecated
P.S.2: 1855 erros de um só componente em menos de 24h não me parece muito saudável para a máquina… message first occured at 5 de agosto de 2019 21:37 and shows up 1855 times
Obrigado Jorge pelas dicas
Consegui resolver o problema desistalando a app da yeelight e refazendo o processo todo novamente… Sinceramente não sei ao certo qual era a razão, o que é certo é que agora está a funcionar.
P.S.: O IPMA agora é configurado através das integrações no interface do HA Loading IPMA via platform config is deprecated
Obrigado, realmente não sabia disso.
P.S.2: 1855 erros de um só componente em menos de 24h não me parece muito saudável para a máquina… message first occured at 5 de agosto de 2019 21:37 and shows up 1855 times
este erro resolvi simpresmente tirando a config do telegram do configuration.yaml, ao que parece entra em conflito por estar tambem configurado no Node Red…
Quanto aos restantes erros da log, ainda estou a resolver