Update Hassio 0.81.5 para 0.86.3

Boas malta,

Tenho o meu hassio desatualizado ( V:. 0.81.5 ), tentei fazer o update para a V:. 0.86.3 e tive muito impacto.

Perdi os meus grupos e quase nada funcionava, botões, sensores, etc…

A minha pergunta o que posso fazer(ir atualizando) para ter o menor impacto possível.

Não tenho o lovelace, se atualizar essa parte já terei a apresentação igual, ou posso perder alguma coisa?

Podes indicar que erros tens nos log por favor?

Como perdi os meus grupos no frontend e algumas funcionalidades, repus o backup, fiz a pergunta para ir atualizando o que estiver em falta de forma a minimizar a atualização.

@Pedro_Oliveira sempre que se actualiza algo, é OBRIGATÓRIO ler as breaking changes.

## Noteworthy breaking changes

Update: the entity ID one was too harsh, it’s not a warning.

This release also includes two noteworthy breaking changes. One is a follow-up on the slugify breaking change from last release. We did not update the validation check for config options that need to be valid slugs. This means that some of your config values might be invalid. Keep an eye at the console as we have a new message to tell you which ones are wrong.

The following things are not allowed in entity IDs:

* No capital letters
* No leading or ending underscores
* No double underscores

This issue also impacts the entity registry, which could contain in some cases invalid entity IDs. Expect entity IDs to change if they contained a double underscore (which becomes 1) or if they started/ended in an underscore (which will be removed).

Another noteworthy breaking change (sorry!), is that the automation  `time`  trigger has been split into two:  `time`  and  `time_pattern` . If you had a time trigger containing the keys  `hours` ,  `minutes`  or  `seconds` , update the platform from  `time`  to  `time_pattern` . 

Podes consultar aqui na página oficial.

Tal como diz o Rodolfo deves ler sempre as breaking changes. No teu caso deves ler de todas as versões entre a 0.81.5 e a 0.86.3

A actualização podes faze-la de duas maneiras: ou alteras o necessário antes e actualizas depois ou actualizas antes e com a ajuda do log fazes as alterações necessárias. Eu pessoalmente prefiro a segunda opção.

90% desses problemas são de não teres o Lovelace configurado.

1 Like

@Pedro_Oliveira ainda assim aconselho primeiro para nao teres esses problemas a instalar o addon
image vai te ajudar depois quando actualizares.

1 Like

Bem pensado @RodolfoVieira!

@Pedro_Oliveira antes da actualização instala o addon. Depois de confirmares que ele cria o ficheiro ui_lovelace.yaml podes desinstalar o addon e actualizar.

1 Like

Este tópico foi automaticamente fechado 90 dias após a última resposta. Novas respostas não são permitidas.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade