Shelly 2.5 perde configuração quando acciono um interruptor de um outro circuito

Olá a todos
Estou com um problema:
Tenho vários Shellys (1 e 2.5) em minha casa, ligados ao Home Assistant.
Tudo funciona bem a maior parte das vezes. O problema acontece quando acendo ou apago uma lampada fluorescente que tenho noutra divisão.
Quando acciono o interruptor dessa lampada, por vezes, o Shelly (2.5) da sala perde a configuração.
Imagino que tal se passe por algum pico ou glitch que o interruptor da lampada fluorescente cause e este interfira com o Shelly.
Estou convencido que se meter um condensador em paralelo com o interruptor que causa a interferencia ( o da lampada fluorescente ), resolvo o problema.
A minha questão é: alguém sabe qual a capacidade e o tipo de condensador a usar ?
Muito obrigado,
Paulo

Bem vindo ao fórum da CPHA @ppsilva e não esqueças de ler os nossos Termos do Serviço/Regras e a FAQ.

A utilização de um filtro (condensador + resistência) serve para o caso de ghost switching, o que não me parece ser pois os sintomas são as luzes apagarem e/ou acenderem aleatoriamente.

Que firmware estás a utilizar nos Shellys?

Boa tarde e obrigado pela atenção.
A versão que estou a utilizar é a 20190822-102551/v1.5.3@1c2d4dd5. Pelo que o Shelly me reporta, é a mais recente. Antes de configurar qualquer um, actualizo sempre o firmware para a última versão.

Algum motivo em especial para estares a usar o firmware original e não o Tasmota, por exemplo?

Podes confirmar se as ligações estão bem feitas e bem apertadas?

Esse problema é estranho e pode ser problema com o próprio Shelly. A melhor maneira de testar é trocar esse Shelly por outro e ver se esse Shelly noutro sítio e o outro Shelly nesse sitio têm o mesmo comportamento.

Essa foi a minha primeira aproximação ao problema.
Troquei o Shelly por outro. Durante 5 dias, tudo bem.
Hoje de manhã, voltou a acontecer ! Verifiquei e voltei a verificar as ligações. Tenho outros 5 Shelly e tudo bem. Só acontece neste. Mas também este é o único que está no mesmo circuito que uma lampada fluorescente, ou seja, é o único num circuito com uma carga indutiva e, ainda por cima com arrancador que provoca de certeza picos de tensão.

Apesar de não ser a resposta à pergunta do OP, porque não trocar a lâmpada fluorescente por uma LED?! :thinking:
Melhor em todos os aspectos… hehe

Pensei nisso, até olhar para a armadura. Quando vi a forma como está presa ao tecto, perdi logo a vontade. É que para por LED tenho k retirar balastro e arrancador da armadura e refazer as ligações … (tanto quanto sei)

Existem umas que é só trocar e até trazem um pseudo arrancador… Mas seria melhor solução retirar o balastro e arrancador, na minha opinião…

De qualquer maneira, o problema subsiste. Há um problema quando houver uma carga deste género. Trocar a lampada fluorescente é contornar o problema. E eu gostaria de o resolver !! :wink:
De qualquer maneira obrigado pela sugestão.

Não é bem contornar… Nos circuitos de luzes, é practicamente impossível vires a ter mais cargas indutivas, assim que se acabarem as lâmpadas fluorescentes… :wink:

Creio que entendi o teu objectivo e pode fazer sentido a utilização de um condensador, para tentar desenrascar. Contudo, será um workaround. O problema poderá estar mesmo na lâmpada florescente. Se for esse o caso, o shelly será só um dos demais equipamentos e lâmpadas a sofrer nesse circuito.

Se tens a certeza que a origem está na lâmpada, só posso dar uma recomendação: Troca essa lâmpada por uma de Leds. Apesar do investimento, a solução será definitiva e vais compensar o retorno do investimento no custo energético com o tempo.

Não obstante do que disse, e dependendo do que está a acontecer no circuito (deverás fazer medições). Mas, mais uma vez deixo a minha alerta e recomendação: Não coloques um condensador e troca a lâmpada.

A melhor maneira de resolver o problema é mesmo acabar com as lâmpadas fluorescentes. Enquanto as tiveres esse problema não desaparece. Existe uns filtros próprios para resolver o problema mas tens sempre de meses na armadura e o preço é muito próximo de uma armadura com lâmpada LED.

Vou fazer o seguinte:
Vou pôr o condensador de 47pF no interruptor (amanhã passo na Mauser e compro).
Entretanto, vou pensar em como raio tirar a armadura do tecto (vai ser pior que meter um Shelly 2.5 na caixa de um comutador de lustre).
Entretanto vou deixando aqui o resultado das várias etapas para referência de alguém que passe pelo mesmo problema.
Já agora uma outra pergunta, relacionada com esta: no caso do “ghost switching”, como referia o @j_assuncao, que valores se costumam usar na malha RC do filtro ?
Mais uma vez, obrigado a todos pela colaboração.

Como diria o outro nem é caro nem é barato, antes pelo contrário… lol…

Mas isso é gastar dinheiro num remendo, devias era atacar o problema e tirar a lampada fluorescente.

O melhor é comprares o filtro que é mais garantido como o que o @j_assuncao recomendou e esquecer o condensador. Como disse os valores devem ser medidos e calculados o identificado pode não servir e … "ser pior a emenda do que o soneto "… e dar um grande estalo na melhor das situações.

Reforço mais uma vez que não deves colocar o condensador !!!

O identificado não deverá servir de exemplo e ser aplicado.

Se pretendes alguma solução diferente de mudar a lâmpada é utilizar o filtro porque garante outro nível de segurança.

Perante os diversas alertas e soluções alternativas, optares por um condensador é procurar problemas para ti e outros e não soluções. Existe um elevado risco de incêndio!!!

Espero que perante todas as alertas, tomes a decisão mais racional e segura e não colocares esse ou outro condensador para resolver o problema identificado.

A consulta de um profissional certificado no local poderá não só vai garantir a identificação correta do atual problema como a segurança de ti e dos teus.

Boa tarde a todos.
Obrigado pelo cuidado @Luis_Andrade.
Eu sou um gajo cuidadoso e tenho alguma formação na área. De maneira nenhuma ia meter “a coisa” sem ver o que poderia dar :wink:
Mas, depois de pensar cuidadosamente, acho que vou mesmo substituir a porcaria da lâmpada fluorescente. E isto pelo seguinte: o fenómeno que dá origem a isto tudo é a FCEM (força contra-electromotriz) gerada pelo balastro aquando da abertura do arrancador. Ora a tensão desta pode ser MUITO elevada e danificar qualquer coisa que esteja no mesmo circuito. Vai daí, vou tomar umas pastilhas de coragem e desmontar a armadura (até suo só de pensar nisso), retirar o balastro e o arrancador e meter LED !!!
Mais uma vez, muito obrigado a todos.

2 Likes

Tomaste a decisão mais inteligente. O teu raciocínio e atitude vai garantidamente dar bons resultados.

Mais vale um pouco de trabalho e investimento com a garantia que fica tudo bem feito e seguires tranquilo para outro projeto.

Para terminar: o LED já lá está, depois de 2 horas de atletismo e contorcionismo.
Mas o meu raciocínio não estava errado !
Quando abri a armadura, sabem o que estava ligado entre a fase e o neutro ???
Pois … um condensador de 22nF !!! (0.022uF). Claramente, o valor não era o adequado, mas que estava lá, estava !!!
:wink:

Esses condensadores podes encontrá-los em todas as armaduras com balastro, vêm de origem para filtrar picos de tensão mas não filtram o ruído introduzido no circuito.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade