Shelly 2.5 não disponivel

Olá malta!

Tenho um shelly 2.5 que sempre esteve on e ok.
Reparei hoje que no HA aparece como indisponível.
Está operável pela App e nas entities não aparece nenhum erro.

Sugestões por favor.
Obrigado

Malta, desculpem ser chato, mas alguém tem alguma ideia do que possa ser?

Como o tens configurado no HA?

Qual a versão que tens do HA, e se isso aconteceu depois de alguma actualização?

Boas,
Já me aconteceu o mesmo algumas vezes (tenho alguns shellies nos estores) .
Normalmente acontece depois de uma actualização do HA mas tenho “resolvido” simplesmente reiniciando o HA.
Se houver uma outra solução mais simples …

A versão é a 0.111.0.
Talvez tenha acontecido, mas não tenho a certeza. Faço sempre as actualizações “sem olhar para trás”, ou seja, se aconteceu devido a isso não dei conta.

Normalmente acontece depois de uma actualização do HA mas tenho “resolvido” simplesmente reiniciando o HA.

No meu caso já reiniciei 3 vezes e para já nada…

Tens isso através de rest ou pela íntegraçao shellyforhass? Podes ver se tens algum erro sobre isso no log.

Está integrado pelo MQTT e o código não foi mexido e por isso não percebo o porquê de agora não ser reconhecido. Ainda assim deixo aqui o código que tenho no configuration.yaml:

    
cover:
  - platform: mqtt
    name: Estore Quarto Gs
    state_topic: "shellies/shellyswitch25-8CAAB505897A/roller/0"
    command_topic: "shellies/shellyswitch25-8CAAB505897A/roller/0/command"
    position_topic: "shellies/shellyswitch25-8CAAB505897A/roller/0/pos"
    set_position_topic: "shellies/shellyswitch25-8CAAB505897A/roller/0/command/pos"
    payload_available: "true"
    payload_not_available: "false"
    qos: 1
    retain: false
    optimistic: false
    payload_open: "open"
    payload_close: "close"
    payload_stop: "stop"
    position_open: 100
    position_closed: 0
    

Não podes ter o Shelly a funcionar simultaneamente na APP da Shelly e através de MQTT. Ou uma coisa ou outra.
Aceder ao shelly através do browser (colocas o IP dele) e verifica se tens o MQTT enable e a cloud disable.
Espero que resolva.

caro @lopitos funcionou.
Agora lembrei-me que de facto já tinha feito isto logo no início. Só não percebi porque alterou, mas pronto, está feito. Obrigado!


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade