Rpi3 + Hassio + ShellyForHASS

olá,

Tenho alguns dispositivos sonoff e shellys.
Tenho tudo a funcionar com o google home e com as aplicações nativas.

Estou a pouco e pouco a muda-las para o RPI3 com Home Assistant e com os sonoffs para já funciona (internamente).

Com o shelly utilizando o ShellyForHASS, não dá erro mas não aparece nenhum dispositivo.
Não me parece ter nenhum erro mas não consigo ver.

para onde devo ver (algum log?) para tentar despistar o problema ?

obrigado , desde já pelas vossas respostas.

RT

E porquê o Shelly4Hass se já existe integração oficial da Shelly no HA?

J_assunção ,

sério ? não encontro. Deveria estar no add-ons do supervisor ? como se chama ?

Chama-se Shelly…

image

P.S.: Eu disse “integração”, não disse “addon”.

image

é esse que eu tenho (veio com o ShellyfotHass), não tem é nenhum device nem entidades.
devo ter qq problema. como despisto ?

no configuration.yaml tenho :

shelly:
cloud_auth_key: “Z…B76D6B”
cloud_server: “https://shelly-911-eu.shelly.cloud

A integração não tem configurações em YAML. Apagas o shelly4hass, as configurações em YAML e reinicias o HA. Depois vais aí adicionar a integração.

não consigo perceber o que estou a fazer mal.
apaguei a configuração no yaml, removi o shelly4hass, reiniciei, voltei a reinstalar, reiniciei e não me aparecem os dispositivos.

anteriormente segui as intruções que dizem :

e tentei fazer a opção cloud.

Mas voltaste a reinstalar o quê? Não há nada para instalar. Apagas tudo o que diz respeito ao Shelly4hass (no HACS e no YAML), reinicias o HA e depois vais às integrações adicionar a integração da Shelly.

:slight_smile: já percebi.

agora o que devo por aqui ?

image

o ip do meu HA? o ip do shelly ? o servidor cloud do Shelly ?

O IP do Shelly que queres adicionar.

não dá.

será que é porque está noutro ip (outro router) ?

o meu Ha esá na gama 192.168.1.??

e o meu shelly (que está on) está na gama 192.168.31.??

será por causa disto ?

image

image

Se estão em redes diferentes de dispositivos diferentes não deve dar. A pergunta que se impõe é: não está tudo na mesma rede porquê?

1 Like

pq tenho 2 routers :frowning:

vou experimentar ligar tudo no mesmo

ok. era isso.

agora tenho de ver como consigo colocar o 2º router na mesma gama do 1º (os shellys estão muito longe do 1º router e quase não chega lá)

obrigado

(foi só tornar este 2º router como extender em vez de router ) ficou ok.


Copyright © 2017-2021. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade