Proxmox - Unable to get device for partition 1 on device /dev/mmcblk0

Ora viva pessoal,

Espero que tenham todos tido umas boas entradas.

Uso HA num raspberry pi mas recentemente comprei um mini pc para colocar lá. Toda a gente fala na flexibilidade do proxmox e em todas as vantagens de performance. Decidi experimentar neste mini pc…correu mal :smiley:

A máquina em questão tem as seguintes características:

Beelink BT3 Pro II:

CPU :Intel Atom x5-Z8350 Processor (2M Cache, up to 1.92 GHz)
Graphics: Intel HD Graphics 400
Memory : 4G
Storage: 64G
Network: 1000Mbps LAN
IEEE 802.11a/b/g/n, 2.4G+5.8G
BT 4.0

Para instalação, fiz uma bootable pen com a versão 6.3 do Proxmox VE. Inseri a pen no mini pc, boot e até aqui ok, abriu o wizard de instalação. Mas depois logo a seguir à introdução dos dados de rede dá o erro: Unable to get device for partition 1 on device /dev/mmcblk0

image

Na net encontrei algumas pessoas a reportar o mesmo, mas sem nenhuma solução.

Alguém já passou por isto? Sabem como se pode resolver?

Muito obrigado,
Nelson

Para que disco meteste a instalar o proxmox? Terá sido para a pen em vez do disco?

Sim, coloquei a instalar para o disco. Apareciam la 3 partições, disco 50 GB e mais duas de 4 MB (boot). Aparentemente estaria tudo certo :disappointed:

Formataste o disco antes e removeste as partições que não querias?

Não! Aquilo vinha com Windows 10, achei que instalando o proxmox ele limpava tudo. Devia formatar? Alguma ferramenta que aconselhes?

Já percebi. O mini pc tem eMMC como disco. O proxmox não deixa instalar neste formato .

Mas é sata e detecta como eMMC ou é mesmo eMMC?

Pelo que vi em vídeos onde abrem o equipamento acho que é mesmo eMMC. Apesar de na descrição não ser claro isso :grimacing:

Liga-lhe um disco Sata pela porta USB

Pois, era o que estava a pensar. Tenho aqui um HDD externo de 1TB, liga ao usb e instalo lã o proxmox. É capaz de funcionar. Não é SSD

os discos externos não sei se são detetados como disco ou se como usb storage, tens de ver isso.
Estes adaptadores usb->sata é que acho que deteta logo como sendo disco

Boa! Obrigado pela resposta Ricardo.

Boa tarde Nelson Silva, acabei de receber o mesmo pc hoje, e estou com o mesmo problema :slight_smile: , resolveu com o disco externo?

Acabei por não optar pelo disco. Uma vez que só terei o home assistant, instalei Ubuntu e criei uma máquina virtual com o hassio. Para já tudo a funcionar bem! :+1:

Devias ter instalado Debian pois é o único SO suportado oficialmente pelo HA.

No tutorial aqui de instalação do HA no Proxmox, a imagem a instalar é Ubuntu. Se o Debian é o único SO com suporte oficial, o tutorial não deveria ser com uma imagem Debian?!

O tutorial foi feito antes do Debian ser o único SO com suporte oficial

1 Like

Ah ok… sendo assim quem vá fazer o tutorial deve utilizar a imagem debian. Estou indeciso entre o tutorial ou a instalação através do script. Mas se é por segurança, acho que vou optar pelo tutorial.

@Nelson_Silva, está a funcionar bem?

Estou a pensar comprar um mini pc para instalar o HA, semelhante ao que referiste, no caso é um bmax (6GB DDR4, 64 GB ROM (eMMC), slot para ligar disco SATA, Intel Celeron N3350) mas queria ver opiniões de quem já experimentou o HA num mini pc…
Pelo teu tópico já percebi que não posso instalar com proxmox no eMMC que ele traz, mas penso que posso instalar o debian, ou então ligar um disco por SATA e usar o proxmox…


Copyright © 2017-2021. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade