Problemas com Z2M e CC2531

Boa noite a todos,

Estive a seguir o tutorial " Como configurar o zigbee2mqtt em Hassio com uma CC2531" mas acontece apôs a reiniciar o Raspberry não me aparece o menu do passo 3 .
Podem me dar uma ajuda?

obrigado

mostra lá o que colocaste no package sff @imrr

@imrr para emparelhar os devices podes evitar esses passos bastando por na tua configuração algo similar a esta (onde está em amarelo)


# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate



mqtt:
    broker: 192.168.1.48
    port: 1883
    client_id: hassio
    keepalive: 60
    username: mosquitto
    password: mosquitto
    discovery: true

input_boolean:
  zigbee_permit_join:
    name: Allow devices to join
    initial: off
    icon: mdi:cellphone-wireless

timer:
  zigbee_permit_join:
    name: Time remaining
    duration: 600 # Updated this to the number of seconds you wish

sensor:
  - platform: mqtt
    name: Bridge state
    state_topic: "zigbee2mqtt/bridge/state"
    icon: mdi:router-wireless

group:
  zigbee_group:
    name: Zigbee
    entities:
      - input_boolean.zigbee_permit_join
      - timer.zigbee_permit_join
      - sensor.bridge_state

automation:
  - id: enable_zigbee_join
    alias: Enable Zigbee joining
    hide_entity: true
    trigger:
      platform: state
      entity_id: input_boolean.zigbee_permit_join
      to: 'on'
    action:
    - service: mqtt.publish
      data:
        topic: zigbee2mqtt/bridge/config/permit_join
        payload: 'true'
    - service: timer.start
      data:
        entity_id: timer.zigbee_permit_join
  - id: disable_zigbee_join
    alias: Disable Zigbee joining
    trigger:
    - entity_id: input_boolean.zigbee_permit_join
      platform: state
      to: 'off'
    action:
    - data:
        payload: 'false'
        topic: zigbee2mqtt/bridge/config/permit_join
      service: mqtt.publish
    - data:
        entity_id: timer.zigbee_permit_join
      service: timer.cancel
    hide_entity: true
  - id: disable_zigbee_join_timer
    alias: Disable Zigbee joining by timer
    hide_entity: true
    trigger:
    - platform: event
      event_type: timer.finished
      event_data:
        entity_id: timer.zigbee_permit_join
    action:
    - service: mqtt.publish
      data:
        topic: zigbee2mqtt/bridge/config/permit_join
        payload: 'false'
    - service: input_boolean.turn_off
      data:
        entity_id: input_boolean.zigbee_permit_joindigite ou cole aqui o código

Por acaso já tinha experimentado como dizes

{
  "data_path": "/share/zigbee2mqtt",
  "devices": "devices.yaml",
  "groups": "groups.yaml",
  "homeassistant": true,
  "permit_join": true,
  "mqtt": {
    "base_topic": "zigbee2mqtt",
    "server": "mqtt://192.168.1.48",
    "user": "mosquitto",
    "password": "mosquitto"
  },
  "serial": {
    "port": "/dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0019365C77-if00"
  },
  "advanced": {
    "pan_id": 6754,
    "channel": 11,
    "network_key": [
      1,
      3,
      5,
      7,
      9,
      11,
      13,
      15,
      0,
      2,
      4,
      6,
      8,
      10,
      12,
      13
    ],
    "availability_blacklist": []
  },
  "ban": [],
  "whitelist": [],
  "queue": {},
  "socat": {
    "enabled": false,
    "master": "pty,raw,echo=0,link=/dev/ttyZ2M,mode=777",
    "slave": "tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5",
    "restartdelay": 1,
    "initialdelay": 1,
    "options": "-d -d",
    "log": false
  }
}

Boa noite,
Não estou a conseguir não sei mais que posso fazer, já fiz vários tutoriais e nada.
Têm mais sugestões que possam ajudar?

obrigado

Bom dia,
Posso não ter compreendido bem a situação, mas sabes que depois de instalar o zigbee2mqtt e colocar o código no configuration.yaml ou em packages, é preciso configurar o lovelace para aparecer o input_boolean e o timer, certo?

1 Like

Vamos por partes:

O addon arranca sem erros? Faz start, espera 1 minuto e depois no log (dentro do addon) carrega em ‘refresh’ e mostra o que aparece.

E será que a pen é mesmo uma CC2531ou é uma CC2540?

Pois isso já não sei eu comprei aqui no forum a um utilizador.
Vou pesquisar como posso ver o tipo.

Obrigado

Basta ver o chip, tem lá escrito a referência. Já tem acontecido, inclusive a mim, enviarem uma CC2540 que é exactamente igual e aceita o mesmo firmware mas é bluetooth.

Boas, aqui vai o codigo:

Log
./run.sh: line 16: [Info] Configuration backup found in /share/zigbee2mqtt/.configuration.yaml.bk. Skipping config backup.: No such file or directory
[Info] Socat is DISABLED and not started
2019-12-17T22:06:32: PM2 log: Launching in no daemon mode
2019-12-17T22:06:33: PM2 log: App [npm:0] starting in -fork mode-
2019-12-17T22:06:33: PM2 log: App [npm:0] online
> zigbee2mqtt@1.8.0 start /zigbee2mqtt-1.8.0
> node index.js
zigbee2mqtt:info  2019-12-17 22:06:48: Logging to console and directory: '/share/zigbee2mqtt/log/2019-12-17.22-06-47'
zigbee2mqtt:info  2019-12-17 22:06:50: Starting zigbee2mqtt version 1.8.0 (commit #unknown)
zigbee2mqtt:info  2019-12-17 22:06:50: Starting zigbee-herdsman...
zigbee2mqtt:info  2019-12-17 22:06:53: zigbee-herdsman started
zigbee2mqtt:info  2019-12-17 22:06:53: Coordinator firmware version: '{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190223}}'
zigbee2mqtt:info  2019-12-17 22:06:53: Currently 0 devices are joined:
zigbee2mqtt:warn  2019-12-17 22:06:53: `permit_join` set to  `true` in configuration.yaml.
zigbee2mqtt:warn  2019-12-17 22:06:53: Allowing new devices to join.
zigbee2mqtt:warn  2019-12-17 22:06:53: Set `permit_join` to `false` once you joined all devices.
zigbee2mqtt:info  2019-12-17 22:06:53: Zigbee: allowing new devices to join.
zigbee2mqtt:info  2019-12-17 22:06:53: Connecting to MQTT server at mqtt://192.168.1.48
zigbee2mqtt:info  2019-12-17 22:06:58: Connected to MQTT server
zigbee2mqtt:info  2019-12-17 22:06:58: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
zigbee2mqtt:info  2019-12-17 22:06:58: MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"version":"1.8.0","commit":"unknown","coordinator":{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190223}},"log_level":"info","permit_join":true}'

Já confirmei é CC2531.
Obrigado

Aparentemente o addon está a funcionar. Agora só tens de emparelhar os equipamentos com o CC2531. Depois tens de executar o procedimento de emparelhamento para cada dispositivo.

Os dispositivos no momento de emparelhamento devem estar relativamente proximos do CC2531. Outra coisa, o CC2531 não deve estar muito próximo de outro emissor radio, ou seja, WIFI, Z-wave etc…
Que dispositivos estás a tentar adicionar?

Z-Wave não trabalha na mesma frequência do zigbee, o Wi-fi sim

1 Like

Apenas para complementar o que o @ricreis394 disse:

Eu sempre li que para emparelhar devemos colocar os dispositivos próximos do CC2531 ou de um router zigbee.
Mas sempre emparelhei os dispositivos logo no local onde os quero deixar e sempre funcionou.
Acredito que possam demorar um pouco mais do que se estiverem perto do coordinator/router, mas nunca tive problemas a emparelhar.

Boas,
Sensores humidade e temperatura Aqara.

Obrigado

@imrr já conseguiste resolver o problema?


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade