Problemas com HTTPs

Boa tarde,

Eu segui este tutorial:

E consegui obter isto:
ssl

Então de seguida, coloquei outra vez as portas de reencanhamento para 443 externa para 8123 interna.

No config.yaml adicionei:

 http:
   base_url: https://xxx.duckdns.org
   ssl_certificate: '/data/letsencrypt/live/xxxx.duckdns.org/fullchain.pem'
   ssl_key: '/data/letsencrypt/live/xxxx.duckdns.org/privkey.pem'

Fui ao add on do duckdns e também alterei para este certificado e para a chave e mesmo assim não consigo aceder de forma https,alguém me poderia dizer o que estou a fazer de errado?

Obrigado pelo vosso tempo,
Marcelo

Não uso duckdns não sei muito como te ajudar. Mas uma coisa tenho a certeza, o base_url agora já não é permitido na configuração, foi parte de uma breaking change há umas semanas atrás.
Vê aqui: https://www.home-assistant.io/integrations/http/

1 Like

Coloquei assim:

 http:
   ssl_certificate: '/data/letsencrypt/live/xxxx.duckdns.org/fullchain.pem'
   ssl_key: '/data/letsencrypt/live/xxxx.duckdns.org/privkey.pem'
   ip_ban_enabled: True
   login_attempts_threshold: 5
   use_x_forwarded_for: true

Mas continua sem funcionar

Eu tenho assim:

http:
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

Depois no configuração, geral, assim:

Obrigado, já consegui! Coloquei isso no configuration.yaml e também o url externo nas definições.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade