Problema a configurar zigbee2mqtt

Boas malta, estou com problemas a tentar configurar o zigbee2mqtt.
tenho a seguinte configuração:

data_path: /share/zigbee2mqtt
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://192.168.1.xxx'
  user: xxxxxxxxx
  password: xxxxxxx
serial:
  port: /dev/ttyAMA0
advanced:
  pan_id: 6754
  channel: 11
  report: true
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blacklist: []
ban: []
whitelist: []
queue: {}
socat:
  enabled: false
  master: 'pty,raw,echo=0,link=/dev/ttyZ2M,mode=777'
  slave: 'tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5'
  restartdelay: 1
  initialdelay: 1
  options: '-d -d'
  log: false

e depois no log do addon tenho erros que não sei como posso resolver.

./run.sh: line 17: [Info] Configuration backup found in /share/zigbee2mqtt/.configuration.yaml.bk. Skipping config backup.: No such file or directory
[Info] Socat is DISABLED and not started
2020-02-25T23:17:23: PM2 log: Launching in no daemon mode
2020-02-25T23:17:23: PM2 log: App [npm:0] starting in -fork mode-
2020-02-25T23:17:23: PM2 log: App [npm:0] online
> zigbee2mqtt@1.10.0 start /zigbee2mqtt-1.10.0
> node index.js
zigbee2mqtt:info  2020-02-25 23:17:26: Logging to console and directory: '/share/zigbee2mqtt/log/2020-02-25.23-17-26' filename: log.txt
zigbee2mqtt:info  2020-02-25 23:17:26: Starting zigbee2mqtt version 1.10.0 (commit #unknown)
zigbee2mqtt:info  2020-02-25 23:17:26: Starting zigbee-herdsman...
zigbee2mqtt:error 2020-02-25 23:18:15: Error while starting zigbee-herdsman
zigbee2mqtt:error 2020-02-25 23:18:15: Failed to start zigbee
zigbee2mqtt:error 2020-02-25 23:18:15: Exiting...
zigbee2mqtt:error 2020-02-25 23:18:15: Error: AREQ - SYS - resetInd after 30000ms
    at Timeout._onTimeout (/zigbee2mqtt-1.10.0/node_modules/zigbee-herdsman/dist/utils/waitress.js:44:24)
    at listOnTimeout (internal/timers.js:531:17)
    at processTimers (internal/timers.js:475:7)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.10.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the zigbee2mqtt@1.10.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Será que alguem me ode dar uma ajuda?

Antes de mais uma pergunta que poderá parecer parva: tens a certeza que é um CC2531? Se puderes coloca uma foto do chip.

1 Like

Sim é CC531 mas logo já coloco foto da mesma.

ok, experimenta desligar o CC 2531 com o addon parado, voltas a ligar a pen e o addon e vê se funciona.

Esse erro que mostras é típico de quando se liga um CC2540 ou similar mas poderá ser outro o problema. Tens o ultimo firmware flashado?

Já agora só para tentar ajudar e comparando com o meu:

a serial_port é mesmo essa? tenho a minha assim

serial:
  port: /dev/ttyACM0

e acho que é a maioria dos casos.

Na linha do server também tenho assim:

  server: 'mqtt://core-mosquitto'

mas aí a tua configuração também parece correcta.

A pen foi flashada por mim. Mas também começo a desconfiar que não ficou bem. Se calhar vai ser melhor fazer o flash de novo. :thinking:

@maxcalavera vou tentar fazer o que o @j_assuncao disse depois dou feedback, caso contrario envio para ti novamente, já que na minha zona não tenho ninguém que a flash .

1 Like

imagem

É mesmo a cc2531

:+1:

Ainda bem que é. Os relatos de pens CC2531 que são enviadas enganadas são cada vez mais.

Dá erro na mesma, vou enviar a pen ao amigo Bruno

2 Likes

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade