NodeRed - Não Inicia

Boas Pessoal,

Ontem desliguei o meu Hassio, para poder fazer os testes com o SSD. Depois disso voltei a ligar tudo, e tudo funciona bem à exceção do NodeRed. Simplesmente não inicia.

Já tentei:

  • Desinstalar e Instalar novamente
  • Repor o snapshot de ontem à noite que o fiz antes de desligar o PI para fazer testes.
  • Desinstalar + apagar a pasta nodered na pasta config + criar o ficheiro db novamente.

Mas depois de tudo ON, quando o tento iniciar dá-me sempre o mesmo erro:

ERROR (SyncWorker_10) [hassio.docker] Can't start addon_a0d7b954_nodered: 403 Client Error: Forbidden ("endpoint with name addon_a0d7b954_nodered already exists in network host")

Ainda bem que apenas desliguei as automações, não as eliminei. :slight_smile:

Alguma ideia de como contornar esta situação?

Se não conseguiste das formas “normais”… provavelmente só indo pelo portainer.

Eu ainda não percebi muito bem o que é o portainer. Mas o portainer não funciona apenas nas instalações com o docker?

E depois de ter feito um “hassio su repair”, reiniciado o OS. quase iniciava. Mas no final diz: “supervisor: died e termina”

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Hass.io Add-on: Node-RED
 Flow-based programming for the Internet of Things
-----------------------------------------------------------
 Add-on version: 6.0.4
 You are running the latest version of this add-on.
 System: HassOS 3.11  (armv7 / raspberrypi4)
 Home Assistant version: 0.105.5
 Supervisor version: 201
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] nginx.sh: executing... 
[cont-init.d] nginx.sh: exited 0.
[cont-init.d] node-red.sh: executing... 
patching file nodes/ui_base.html
Hunk #1 succeeded at 1243 (offset 712 lines).
npm notice created a lockfile as package-lock.json. You should commit this file.
up to date in 9.189s
found 0 vulnerabilities
[cont-init.d] node-red.sh: exited 0.
[cont-init.d] user.sh: executing... 
[cont-init.d] user.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[11:20:24] INFO: Starting Node-RED...
> hassio-addon-node-red@ start /opt
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"
19 Feb 11:20:31 - [info] 
Welcome to Node-RED
===================
19 Feb 11:20:31 - [info] Node-RED version: v1.0.3
19 Feb 11:20:31 - [info] Node.js  version: v12.14.0
19 Feb 11:20:31 - [info] Linux 4.19.93-v7l arm LE
19 Feb 11:20:32 - [info] Loading palette nodes
Terminated
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing... 
[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
s6-svwait: fatal: supervisor died
[s6-finish] sending all processes the TERM signal.

Não faz muito sentido para mim, talvez para vocês sim. Mas comecei a tentar outras coisas a ver se funcionava.

E o NodeRed começou a funcionar depois de eu ter alterado require_ssl: false

Apesar de o meu HA estar a usar SSL.

credential_secret: password
dark_mode: false
http_node:
  username: ''
  password: ''
http_static:
  username: ''
  password: ''
ssl: true
certfile: fullchain.pem
keyfile: privkey.pem
require_ssl: false
system_packages: []
npm_packages: []
init_commands: []

Esse erro indica que já existia um container com o mesmo nome e por isso não instalou.

Como acedes ao NR dentro da tua rede?

@j_assuncao
Não é ao instalar. Ele instalou, o problema foi só mesmo ao iniciar o addon.

Tanto dentro como fora da rede costumo aceder da mesma maneira sempre pelo https://myhost.duckdns.org

E depois ao NR, dentro do próprio HA.

Dentro da tua própria rede se acederes por http://ip-do-ha:8123 tens algum erro?

qual a tua config em base_url?

Demorei um bocado, porque ainda tive de me ligar lá a casa.

Neste momento, http://ip-do-ha:8123 abre o HA normalmente, sem erro.

A configuração em http_base_url é aquela “parva” que já falamos em outros posts.

Simplesmente não existe, está comentada.

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
#http:
#  base_url: myhost.duckdns.org
#  ssl_certificate: /ssl/fullchain.pem
#  ssl_key: /ssl/privkey.pem

# Text to speech
tts:
  - platform: google_translate
    base_url: http://ip-do-ha:8123

Se o endereço http://ip-do-ha:8123 não te dá erro, é esse que deves usar dentro da tua rede e não o do DuckDNS.

Alem disso a entrada base_url deve fazer parte da configuração e com o valor:

base_url: ip-do-ha:8123

Eu logo experimento colocar a entrada base_url.

Mas eu tenho tudo a funcionar baseado neste tutorial:

E nesse tutorial ela diz que se deve comentar essa linha.

Aqui no fórum também há um tutorial sobre isso:

Eu sei @j_assuncao

E eu tentei esse e outros.

Mas este que ela criou, penso porque o google dentro da rede não comunicava para o exterior. Mas no meu caso, como ainda não tenho nenhum equipamento desses, foi mesmo para que a app do HA para Android, abri-se com o mesmo endereço fosse dentro ou fora da rede.

Porque era chato estar sempre a mudar de endereço para abrir a app, no telemóvel.

E neste momento não vou mudar muito, até porque estou à espera dos equipamentos necessários para instalar o SSD. E aí estou a pensar instalar tudo de fresco.

Mas já agora nesse tutorial, não fala do Nginx. Não é necessário a instalação desse addon para ter o dominio a funcionar fora com a porta de https 443?

Não fala porque não é preciso. Tem a ver com quem gere o pedido dos certificados, ou o DuckDNS ou o NGINX Proxy Manager.

Eu uso o NGINX Proxy Manager e dentro da minha rede uso apenas o endereço http://ip-do-ha:8123 para aceder ao HA e todos os addons têm o ssl: false activo. E não tenho problemas em me ligar através da aplicação porque a que eu uso é inteligente o suficiente para saber quando tem que usar o http ou https (coisa que a suposta app oficial julgo que não faz).

Ok. Vou ver isso ao instalar o SSD e simplificar o processo então.

Em tremos de aplicação, falas da Ariela, correto? Em vez da app oficial do HA.

Sim, falo da Ariela que tem umas dezenas de funções extra que duvido a app oficial venha a ter.

1 Like

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade