Home Assistant + MQTT + Shelly

Viva,

Estou com problemas em integrar os meus Shelly 1 no Home Assistant.

Tenho o broker a correr, os dispositivos aparecem na UI mas não consigo alterar o estado.

Plataforma:

  • Win10
  • Home Assistant a correr numa VM Hyper-V
  • Versão do HA: 0.105.2

configuration.yml

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

sun:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:
  base_url: https://xxxxxxxxxx:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

light:

    ###########################
    #
    #          Shelly 
    #
    ###########################
    
  - platform: mqtt # TIPO: Luz
    name: qp_luz_closet
    state_topic: "shellies/shelly1-C489A1/relay/0"
    command_topic: "shellies/shelly1-C489A1/relay/0/command" 
    payload_on: "on"
    payload_off: "off"
    payload_available: "true"
    payload_not_available: "false"
    optimistic: false
    qos: 0
    retain: false

  - platform: mqtt # TIPO: Luz
    name: qp_luz_tecto
    state_topic: "shellies/shelly1-C4849F/relay/0"
    command_topic: "shellies/shelly1-C4849F/relay/0/command"
    payload_on: "on"
    payload_off: "off"
    payload_available: "true"
    payload_not_available: "false"
    optimistic: false
    qos: 0
    retain: false
    

Configuração mosquitto:

logins: []
anonymous: false
customize:
  active: false
  folder: mosquitto
certfile: fullchain.pem
keyfile: privkey.pem
require_certificate: false

Log do mosquitto:

[21:03:39] INFO: Setup mosquitto configuration
[21:03:39] INFO: No local user available
[21:03:39] INFO: Initialize Hass.io Add-on services
[21:03:39] INFO: Initialize Home Assistant discovery
[21:03:39] INFO: Start Mosquitto daemon
1581282219: mosquitto version 1.6.3 starting
1581282219: Config loaded from /etc/mosquitto.conf.
1581282219: Loading plugin: /usr/share/mosquitto/auth-plug.so
1581282219: |-- *** auth-plug: startup
1581282219:  ├── Username/password checking enabled.
1581282219:  ├── TLS-PSK checking enabled.
1581282219:  └── Extended authentication not enabled.
1581282219: Opening ipv4 listen socket on port 1883.
1581282219: Opening ipv6 listen socket on port 1883.
1581282219: Opening websockets listen socket on port 1884.
1581282220: Opening ipv4 listen socket on port 8883.
1581282220: Opening ipv6 listen socket on port 8883.
1581282220: Opening websockets listen socket on port 8884.
1581282220: Warning: Mosquitto should not be run as root/administrator.
1581282220: New connection from 172.30.32.1 on port 1883.
[INFO] found homeassistant on local database
1581282221: New client connected from 172.30.32.1 as auto-58EE19B8-14F0-47C7-8AD4-035DEB6DA1E8 (p2, c1, k60, u'homeassistant').

Configuração do Shelly:

IP: ip do HA
Clean

Caso não tenhas o addon do mosquitto actualizado, actualiza, de seguida tens que alterar a config do addon, a que tens actualmente não declaraste um usernam e password.

Terá que ser:

logins:
  - username: username
    password: password
anonymous: false
customize:
  active: false
  folder: mosquitto
certfile: fullchain.pem
keyfile: privkey.pem
require_certificate: false

O username e password terá que ser identico ao que colocaste na app da shelly

Viva Rodolfo,

Fiz a alteração sugerida mas não teve efeito.

Versão do mosquitto: 5.1

obg

Boas.

No meu shelly tenho:

    state_topic: "shellies/shellyswitch25-XXXXXX/roller/0"

No meu caso é para controlo de estores.
Onde tens apenas shelly1 troca por shellyswitch1 e vê se funciona.

Mas antes confirma isso carregando na opção " Use custom MQTT prefix" conforme a imagem a baixo.

Abraço.

Não te falta também configurar o mosquito no configuration.yaml ?

ou já o configuras-te através das integrações depois de teres actualizado com o username e a password?

Eu tenho isto no configuration.yaml

mqtt:
  broker: 192.168.x.xx
  port: 1883
  username: username
  password: password
  keepalive: 60

@finipini isso que usas podes apagar e usar directamente a integração…isso vai desapare er em breve.

Ok. Estava a tentar perceber se o @lopitos tem o mqtt configurado nas integrações e se sim se ele actualizou depois de ter adiccionado o user e a pass na config. do mosquitto.

1 Like

Funcionou…

O mais engraçado é que inicialmente tinha a configuração desse modo e não funcionou.

Passei literalmente o fds de volta deste tema…

Obg pelo apoio/sugestões :slight_smile:

1 Like

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade