HA "morre" todos os dias

Bom dia.

Preciso de alguma ajuda vossa.

Todos os dias o meu HA (RPi3b+) “morre”/fica inacessível durante a madrugada. Quando detecto isso reinicio (plug-out/plug-in) e volta a funcionar bem, no entanto nota-se que todos os sensores não tiveram dados durante esse período. Como a minha principal razão de uso do HA é ter dados de sensores de consumos, perder algumas horas por dia estraga tudo.
Nos logs (basicos) não vejo nada, até porque com o reboot deve perder-se alguma coisa.

De que forma posso perceber o que estará a causar isto?

Obrigado.

O Rpi fica mesmo desligado? Ou está ligado mas inacessível?
No caso de apenas ficar inacessível, consegues de alguma forma ligar o monitor ao Rpi para perceber se existe alguns logs de erro?

O meu tinha sintomas parecidos e eventualmente o cartão SD morreu. Aconteceu duas vezes.
Suspeitava disso e mantinha os backups em dia.

A melhor coisa que fiz foi upgrade para o rpi4 + ssd hat e agora está turbinado :slight_smile: e deve durar muito mais tempo que anteriormente.

1 Like

Ele fica ligado, e alguma coisa faz já que a porta de rede (e mesmo a luz de processamento) dão sinal. Fica é inacessível, o que faz pensar que é a instância HA que morre.

Qual foi o investimento nesse kit?

Investe 25 ou 40€ numa box android e ficas servido

@Carlos_Castro qual foi o tipo de instalação que usaste para instalar o HA nesse rpi?

Caso, estejas a usar Addons quais estás a usar?

Olá Rui,

Olha, comprei o rpi4 + box + fonte na mauser.pt e ficou tudo ~79€
Depois comprei o hat no ebay (https://www.ebay.com/itm/184105174336) e fica à volta de 22€. Como o rpi4 já tem usb 3.0 e este hat é usb 3.0 ficas com a performance toda disponível.

O disco msata eu por acaso já tinha, e é um de 60GB da Kingston (chega bem) mas não me recordo do preço. No entanto, segundo o KuantoKusta um de 120GB custa à volta de ~38€ (https://www.kuantokusta.pt/informatica/Armazenamento/Discos-SSD/Kingston-120GB-UV500-mSATA-SUV500MS-120G-p-1-548733)

Assim por alto fica 140€ mas a parte boa é que deixas de ter chatices. O meu nunca mais me deu problemas de fiabilidade. Ganhas confiança porque o msata dura muito mais que um SD, ganhas velocidade porque o msata tem muito mais performance e acima de tudo, descanso.

Como não tenho foto do meu partilho uma da net, mas tem este aspecto no final (a minha caixa não tem as ventoinhas para ser mais silencioso)

E em termos de temperaturas aguenta-se muito bem por volta dos 44-48º

Uma coisa que ninguém pensa e que pode eventualmente estar a acontecer, será alguma condição imposta pelo router, deixando de funcionar a determinadas horas. Algo parecido como o controle parental. Há routers que tem essa facilidade. Se não souberes como chegar lá, podes sempre impor outro IP ao Pi e confirmar se continua a acontecer.

Não me parece José, tenho um lease time de 60000s e nem sequer é a horas certas, hoje aconteceu entre a 01:00 e as 06:00 e novamente das 10 às 13/14

Mas, vendo os logs do router:
Oct 22 00:37:18 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:37:18 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:37:18 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:37:18 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:46:19 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:46:19 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:46:19 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 00:46:19 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 01:15:38 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 01:15:38 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 01:15:38 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly
Oct 22 01:15:38 miniupnpd[17151]: HTTP Connection from 192.168.31.51 closed unexpectedly

Router Asus RT-AC1200G+

Para um investimento desse ias melhor servido com um NUC, não?

Sim, é uma opção válida também. Mas por 140€ creio que seja dificil arranjar um NUC ou já se consegue alguma opção de jeito com esse valor? :thinking:

@rjmsilveira não vamos alimentar este tópico com a conversa de NUCS se faz favor.
Caso queiras, dar continuidade a essa questão existe tópicos que abordam essa vertente.
Obrigado

Bem, infelizmente continua a “morrer” e já percebi que não é só de madrugada. tenho cenários em que fica inacessível de manhã, durante a tarde, etc. em alguns casos não detecto logo e até volta à vida ao final de umas horas (notando-se que durante aquele tempo não registou qualquer sensor), noutros precisa mesmo de um force reboot (power cycle).

Alguém sabe se há algum log que guarde estes “fatal errors” que poderão estar a acontecer?

Já desliguei:

  • UNPN no router
  • integração UNPN
  • backup gdrive

Mesmo assim nada.

que box sugeres? pelo que vi aqui no forum o post sobre isso não recomenda.

Já tentás-te substituir o sdcard? Já substituíste a fonte de alimentação do PI? parece-me ser uma causa provável. No passado já tive esse problema!
Se for assim tão frequente os crashes eu ainda desligaria o PI da rede para perceber se o problema está do lado do Pi ou do router.

Viva, sim, já troquei o SD e já troquei a fonte (agora tenho um carregador de 4A da oneplus).

Desligando do router não teria grande benefício já que deixaria de ter acesso aos sensores e não ia conseguir perceber se estava activo ou não.

Fiz uma nova tentativa e é desesperante. Nova instalação, cartão SD de 64GB Samsung Gold cat10
Passadas umas horas, falhou de novo. Voltou à vida 5h depois, mas não consigo encontrar liga que ajudem.

@Carlos_Castro vou voltar a perguntar te que addons estás a usar?


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade