Grafana duvida a configurar

segui este tutorial : 📑 Como instalar e configurar os addons InfluxDB e Grafana no Hassio

mas nao me apareçe isto:
Vai aparecer um quadro tipo este… mas ainda com o gráfico vazio, mas o que tu tens que fazer é editar tudo o que está no quadro vermelho

parece-me que no meu nao esta configurado o add data source e o new dashboard…
No meu nao tem os vistos na 2º e 3º opçao, so na primeira ( do install grafana)
como faço ?
obrigado

Podes explicar isso com umas imagens?


aqui escolho o k ?

o create a data source nao fica com visto… :

ao fazer o edit no title:
ao carregar no select measurement nao me apareçem valores:
image

que se passa ? o teste a base de dados diz que foi com sucesso…

aqui apareçe :


alguem pode ajudar ?

1º Choose Visualization

2º Esquece o que aparece ai ou não aparece

3º Tens que escolher uma unidade de medida para te aparecerem os sensores que usam essa unidade de medida.

nao me apareçe nehuma unidade de medida:

fica em branco…

ao fazer edit no panel tittle nao me apareçe nada:

apareçe um erro nos logs:

acho q esta a dar um erro:

Database host is not accessible due to ‘HTTPConnectionPool(host=‘a0d7b954_influxdb’, port=8086): Max retries exceeded with url: /write?db=homeassistant (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0xffff8044b990>: Failed to establish a new connection: [Errno -3] Try again’))’, please check your entries in the configuration file (host, port, etc.) and verify that the database exists and is READ/WRITE. Retrying again in 60 seconds. 14:22 components/influxdb/init.py (WARNING)

Isso é um erro de ligação com a BD. Criaste tu a BD ou foi automático?

criei eu a base de dados…

Então tens problemas de permissões ao aceder à BD. Deste as permissões correctas ao utilizador?

sim all

Que configurações tens no HA para o InfluxDB e Grafana? E que configurações tens para os addons do InfluxDb e Grafana?

no ha: conf.

  #host: a0d7b954_influxdb
  host: 127.0.0.1
  port: 8086
  database: homeassistant
  username: !secret user_influxdb
  password: !secret password_influxdb
  max_retries: 3
  default_measurement: state ```
 
no addon do  InfluxDB:
``` {
  "auth": true,
  "reporting": true,
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "envvars": [
    {
      "name": "INFLUXDB_HTTP_LOG_ENABLED",
      "value": "true"
    }
  ],
  "log_level": "info"
}```
e no grafana:
``` {
  "plugins": [],
  "env_vars": [],
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}```

Podes apagar as seguintes linhas que não fazem falta:

max_retries: 3
default_measurement: state

Caso não uses SSL para aceder ao HA podes colocar o "ssl": false em ambos os addons.

esta igual, nao consigo fazer os graficos …

ja funca tanks … alterei o host no config para o 127.0.0.1 e ficou a dar…

Estava com o mesmo problema.

Coloquei SSL false e resolveu.

ssl: false
verify_ssl: false

isso onde no ficheiro config. ? ou no add on?

@Skysurf ficamos um pouco confusos, no teu post anterior disseste que já funcionava , agora levantas outra questão que já foi aqui respondida?


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade