Estabelecer comunicação entre Home Assistant e PCB's DENKOVI

Olá,

Recentemente tive conhecimento da óptima plataforma “HomeAssistant”, a qual já se encontra instalada(Raspberry) e interiorizada na minha instalação juntamente com alguns equipamentos que tenho experimentado.

Inicialmente vi alguns tutoriais que me deram a conhecer este método de acesso aos equipamentos sem ter que usar aplicações individuais para comunicação com os diversos dispositivos.

A minha dúvida ocorre quando tento introduzir / configurar uma board que tenho em funcionamento, nomeadamente, “Ethernet 12 relay module - Web, TCP/IP, Telnet, HTTP API, E-mails” no HA.

Após ter seguido as instruções dadas pelo fornecedor do equipamento para iteração com o HA, não obtive sucesso nas demais tentativas, dai pedir apoio para tal!

[Devo informar que sou iniciante no que toca ao HA, e adoro tudo o que envolve Electricidade e Telecomunicações, mas no entanto percebo apenas algumas coisas de linguagem de programação, tendo interesse em aprofundar esse conhecimento.

Desde já agradeço a vossa ajuda!

Explica melhor como fizeste e que erros te dá.

Tens aqui um tutorial: http://denkovi.com/home-assistant-and-denkovi-modules

O meu interesse em estabelecer a comunicação entre o HA e a board Denkovi nasceu a partir do momento que vi no website que indicaste passo-a-passo como se fazia.

Tentei várias situações:

  • primeiro fiz como diz no tutorial
    - Fiz download dos ficheiros através do link indicado;
    - Copiei o ficheiro “secrets.yaml” para a pasta “config” no HA;
    - Copiei através do FILEZILLA para o HA os ficheiros das pastas “HA.DAEnetIP3.HTTP”, “HA.DAEnetIP3.TCP1” e “HA.DAEnetIP3.TCP2” já alterando os IP’s, portas e pass como pede. Fiz 3 tentativas, uma com cada pasta porque não consegui perceber qual delas seria. O meu controlador é o DAEnetIP3 s/ wifi;
    - Fiz check á configuração estava ok.
    - Por fim fiz RESET e quando liguei não apareceu nada de novo.

Segunda tentativa:
- copiei na mesma os ficheiros da respectiva pasta DENKOVI para a pasta “config” no HA e alterei novamente as portas, IP’s e pass, mas em vez de transferir o ficheiro “configuration.yaml” alterei o ficheiro de origem no HA e inseri as informações daquele que ia copiar para lá.
- Fiz Check á configuração e não consegui que ficasse ok.!

Informações da board DENKOVI:
- IP: 192.168.1.111
- Portas: 80
- Pass: pmbs1

Não sei se estou a conseguir traduzir o meu problema… :confused:

@Paulo_Sousa isso é uma mensagem de código e como tal é texto não devendo ser utilizada uma foto. Por favor apaga a foto e coloca o texto devidamente formatado. Para publicares código deves sublinhar o texto que queres transformar em código e clicar no icone </>. Deverá existir um espaço antes e outro depois do bloco de código para que funcione correctamente.

Ups… peço desculpa!

O problema é que sou um bocado “leigo” em linguagem de programação e como tal tenho alguma dificuldade em exprmir as minhas dúvidas através desse método.

Acho que vou precisar de uma ajudinha extra para conseguir lá chegar.

Conseguem dar algum exemplo do que me indicaram?!

Configuração presente na pasta a transferir para o HA.

homeassistant:
  name: Casa
  latitude: !secret home_lat
  longitude: !secret home_long
  unit_system: metric
  time_zone: Europe/Sofia
  customize_glob:
    sensor.hidden*:
      hidden: true
    weather.vkshchi:
      hidden: true

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate

# Include board specific configuration files
#######################################
# DAEnetIP3 (TCP) - Example 1
#######################################
group: !include DAEnetIP3.TCP1/groups.yaml
sensor: !include DAEnetIP3.TCP1/sensors.yaml
switch: !include DAEnetIP3.TCP1/switches.yaml
rest_command: !include DAEnetIP3.TCP1/rest_commands.yaml

Minha configuração existente no HA.

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate
  
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

# SonOFF
sonoff:
  username: xxxxxx
  password: xxxxxx
  scan_interval: 60 #(optional, lower values than 60 won't work anymore!)
  grace_period: 600 #(optional)
  api_region: 'eu' #(optional)

# Denkovi
  group: !include DAEnetIP3.HTTP/groups.yaml
  sensor: !include DAEnetIP3.HTTP/sensors.yaml
  switch: !include DAEnetIP3.HTTP/switches.yaml
  rest_command: !include DAEnetIP3.HTTP/rest_commands.yaml

@Paulo_Sousa conseguiste por a funcionar? Se não conseguiste passa no discord fala comigo para fazermos alguns testes.
Obrigado


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade