Erros Zigbee2mqtt Plugin

Boa tarde,

Instalei o Hassio num Raspberry PI 1 até aqui tudo bem consigo aceder ao Home assistant já me aparecem alguns equipamentos que tenho. Sou iniciado nestas andanças do Home assistant no passado e durante algum tempo utilizei Domoticz.

Agora estou a tentar integrar Zigbee no Home assistant. Flashei a pen zigbee e configurei o MQTT seguindo alguns tutoriais aqui do foum (📑 Como configurar o zigbee2mqtt em Hassio com uma CC2531)

Neste momento o MQTT parece estar a funcionar mas foi adicionado através dos plugins do HASSIO.

instalei tambem o zigbee2mqtt no entanto a brigde aparece sempre offline e no log aparece o seguinte erro.

[Info] Configuration file found: /share/zigbee2mqtt/configuration.yaml
[Info] Configuration written to /share/zigbee2mqtt/configuration.yaml
2019-02-28T22:44:31: PM2 log: Launching in no daemon mode
2019-02-28T22:44:34: PM2 log: App [npm:0] starting in -fork mode-
2019-02-28T22:44:34: PM2 log: App [npm:0] online

zigbee2mqtt@1.1.1 start /zigbee2mqtt-1.1.1
node index.js
zigbee2mqtt:info 2/28/2019, 10:45:14 PM Logging to directory: ‘/share/zigbee2mqtt/log/2019-02-28.22-45-14’
zigbee2mqtt:info 2/28/2019, 10:45:25 PM Starting zigbee2mqtt version 1.1.1 (commit #unknown)
zigbee2mqtt:info 2/28/2019, 10:45:25 PM Starting zigbee-shepherd
zigbee2mqtt:info 2/28/2019, 10:45:29 PM Error while starting zigbee-shepherd, attemping to fix… (takes 60 seconds)
zigbee2mqtt:info 2/28/2019, 10:46:29 PM Starting zigbee-shepherd
zigbee2mqtt:error 2/28/2019, 10:46:33 PM Error while starting zigbee-shepherd!
zigbee2mqtt:error 2/28/2019, 10:46:33 PM Press the reset button on the stick (the one closest to the USB) and start again
zigbee2mqtt:error 2/28/2019, 10:46:33 PM Failed to start
{“message”:“request timeout”,“stack”:“Error: request timeout\n at CcZnp. (/zigbee2mqtt-1.1.1/node_modules/cc-znp/lib/ccznp.js:255:22)\n at Object.onceWrapper (events.js:273:13)\n at CcZnp.emit (events.js:182:13)\n at Timeout. (/zigbee2mqtt-1.1.1/node_modules/cc-znp/lib/ccznp.js:234:18)\n at ontimeout (timers.js:436:11)\n at tryOnTimeout (timers.js:300:5)\n at listOnTimeout (timers.js:263:5)\n at Timer.processTimers (timers.js:223:10)”}

Já tentei fazer o procedimento que indica no log carregar na PEN no botão mais perto do USB. Sem sucesso.

Segue tambem o log do MQTT.

INFO] Setup mosquitto configuration
[WARN] SSL not enabled - No valid certs found!
[INFO] No local user available
[INFO] Initialize Hass.io Add-on services
[INFO] Initialize Home Assistant discovery
[INFO] Start Mosquitto daemon
1551392973: mosquitto version 1.4.15 (build date 2018-03-04 15:35:59+0000) starting
1551392973: Config loaded from /etc/mosquitto.conf.
1551392973: *** auth-plug: startup
1551392973: ** Configured order: http
1551392973: Opening ipv4 listen socket on port 1883.
1551392973: Opening ipv6 listen socket on port 1883.
1551392973: Opening websockets listen socket on port 1884.
1551392974: Warning: Mosquitto should not be run as root/administrator.
1551394774: Saving in-memory database to /data/mosquitto.db.
1551396575: Saving in-memory database to /data/mosquitto.db.
1551398376: Saving in-memory database to /data/mosquitto.db.
1551400177: Saving in-memory database to /data/mosquitto.db.
1551401978: Saving in-memory database to /data/mosquitto.db.
1551403779: Saving in-memory database to /data/mosquitto.db.
1551405580: Saving in-memory database to /data/mosquitto.db.
1551407381: Saving in-memory database to /data/mosquitto.db.
1551409182: Saving in-memory database to /data/mosquitto.db.
1551410983: Saving in-memory database to /data/mosquitto.db.
1551412784: Saving in-memory database to /data/mosquitto.db.
1551414585: Saving in-memory database to /data/mosquitto.db.
1551416386: Saving in-memory database to /data/mosquitto.db.
1551418187: Saving in-memory database to /data/mosquitto.db.
1551419988: Saving in-memory database to /data/mosquitto.db.
1551421789: Saving in-memory database to /data/mosquitto.db.
1551423590: Saving in-memory database to /data/mosquitto.db.
1551425391: Saving in-memory database to /data/mosquitto.db.
1551427192: Saving in-memory database to /data/mosquitto.db.
1551428993: Saving in-memory database to /data/mosquitto.db.
1551430794: Saving in-memory database to /data/mosquitto.db.
1551432595: Saving in-memory database to /data/mosquitto.db.
1551434396: Saving in-memory database to /data/mosquitto.db.
1551436197: Saving in-memory database to /data/mosquitto.db.
1551437998: Saving in-memory database to /data/mosquitto.db.
1551439799: Saving in-memory database to /data/mosquitto.db.
1551441600: Saving in-memory database to /data/mosquitto.db.
1551443401: Saving in-memory database to /data/mosquitto.db.
1551445202: Saving in-memory database to /data/mosquitto.db.
1551447003: Saving in-memory database to /data/mosquitto.db.
1551448804: Saving in-memory database to /data/mosquitto.db.
1551450605: Saving in-memory database to /data/mosquitto.db.
1551452406: Saving in-memory database to /data/mosquitto.db.
1551454207: Saving in-memory database to /data/mosquitto.db.

Ao nivel de config:

MQTT:
{
“logins”: [],
“anonymous”: false,
“customize”: {
“active”: false,
“folder”: “mosquitto”
},
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
}

ZIGBEE2MQTT:
{
“data_path”: “/share/zigbee2mqtt”,
“homeassistant”: true,
“permit_join”: false,
“mqtt_base_topic”: “zigbee2mqtt”,
“mqtt_server”: “mqtt://ipdoraspberry:1883”,
“serial_port”: “/dev/ttyACM0”,
“devices”: [],
“network_key”: [],
“mqtt_user”: “user”,
“mqtt_pass”: “password”,
“log_level”: “debug”
}

Fico a aguardar alguma ajuda para ver se consigo arrancar.

no zigbee addon tens de por o IP do rpi tipo
"mqtt_server": "mqtt://192.168.1.90",

e na secçao

“mqtt_user”: “user”,
“mqtt_pass”: “password”,

o user e pass que puseste no mosquito

Sim isso é o que tenho apenas alterei para não colocar aqui os dados…

no mqtt_serve tenho ip do RPI.

No mqtt_user e mqtt_pass tenho a password e utilizador que criei para o MQTT. Na partica um utilizador que crei na tab “Configuration” - “Users” do Home Assistant.

Alguem me pode dar uma ajuda?
Obrigado

@goncaloazevedo
Na linha “mqtt_server”: “mqtt://ipdoraspberry:1883” experimenta sem a porta, assim: “mqtt_server”: “mqtt://ipdoraspberry”.

É como tenho a minha configuração.

Boas,

Já tentei tambem não resolveu exactamente o mesmo erro.

E isso quer dizer o quê?

Fiz a alteração mas continua a dar exactamente o mesmo erro.

na linha “serial_port”: “?!!??!?!”, devo ter /dev/ttyACM0 ou /dev/ttyAMA0 como consigo verificar em que serial está ligado?

Se tens Hassio vai a Hassio > System > Hardware e tens lá o nome das portas utilizadas.

Sim é ai que tenho ido ver mas tenho
/dev/ttyACM0
/dev/ttyAMA0

e apenas tenho 1 device usb ligado…

O meu é 9 acm0. Testa os dois e vê se algum finc9na

Já consegui resolver.
Não tenho a certeza de como mas basicamente coloquei a configuração default no plugin zigbee2mqtt e depois acedi por ssh a pasta /share/zigbee2mqtt/configuration.yaml e coloquei a seguinte configuração:

advanced:
log_level: debug
homeassistant: true
mqtt:
base_topic: zigbee2mqtt
password: password
server: ‘mqtt://ipraspberrypi’
user: username
permit_join: true
serial:
port: /dev/ttyACM0

Fiz restart ao HAssio e a dongle USB e partir desse momento arrancou online.

Obrigado pela ajuda.

1 Like

Ainda não perdi muito tempo com isso, mas já reparei que a info que se coloca no addon não passa para o ficheiro yaml da pasta zigbee2mqtt. Andava á nora com um problema destes e descobri que o ip do broker estava correto no addon mas errado no ficheiro.

Por vezes perde-se menos tempo se se ler as páginas oficiais dos componentes que se estão a usar. As configurações do addon não “passam” para o configuration.yaml do zigbee2mqtt. A pagina oficial diz desde a ultima versão:

overwrite - Set this to false to disable overwriting any configuration defined in the zigbee2mqtt configuration YAML file when the add-on starts. Useful if you want to manually alter your configuration.yaml file. By default, this is set to true , meaning any options set in the Hass.io frontend will replace their corresponding entry in the configuration file, if present.

Com esta configuração podem definir qual a prioridade das configurações. Para usar as configurações do addon usam overwrite: true, para usar as configurações do ficheiro configuration.yaml usam overwrite: false.

Não sabia disso, mas como disse, ainda não tinha perdido muito tempo com isso porque consegui resolver. Mas se em default está em “true” devia tomar atenção ao ao que está no addon, e não foi o caso. Alterei o ip no yaml e passou a fucnionar.

Este tópico foi automaticamente fechado 90 dias após a última resposta. Novas respostas não são permitidas.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade