Erro ubuntu ao instalar pacote necessário

iniciei hoje a instalacao do Home Assistant numa maquina com ubuntu 18 e quando faço comando
“sudo apt-get install docker.io avahi-daemon jq” aparece-me este erro :
E: Unable to locate package docker.io
E: Couldn’t find any package by regex ‘docker.io

anteriormmente fiz :

sudo apt-get update
sudo apt-get -y upgrade

e correu tudo sem erros , será que alguem me da uma ideia do que possa estar a acontecer ?

Na altura que instalei, o script de instalação não suportava o 18. Não estive para me chatear e instalei o 16 LTS.
Mais tarde encontrei uma versão que supostamente já instalava no 18, mas nunca testei.

Não me lembro exactamente se o problema era no docker, mas até hoje nunca tive problemas.

Assim de repente, e porque estar a fazer troubleshoot de linux é complicado no fórum sugeria tentares o 16LTS (xenial xerus)

vou entao instalar o 16LTS e experimentar , só que fica a duvida … se fizer
sudo apt-get update
sudo apt-get -y upgrade

nao irá para a ultima versao 18 ?

Não. Vai fazer upgrade aos pacotes dentro da 16

1 Like

Este tópico foi automaticamente fechado 90 dias após a última resposta. Novas respostas não são permitidas.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade