Energy Management in Home Assistant

Boa noite,

Seria possivel a vossa ajuda…com esta nova funcionalidade do Energy Management in Home Assistant, tenho um efergy a pedir o meu consumo que esta pedir em Watts mas nao aparece como opcao mas os shelly que controlam os estores e outro shelly que mede consumo do frigorífico estao na lista. Sei que so devia aparecer Kwh mas tb tenho integraçao com PVOUT mas nao aparece.
Alguem consegue dar uma idea como resolver este problema?
Tb tenho assim:

  • platform: integration
    source: sensor.efergy_xxxxxxx
    name: energy_spent
    unit_prefix: k
    round: 2

Mesmo assim nao aparece na lista

Obrigado e grande abraço

Ainda não analisei a fundo esta nova funcionalidade mas acho que só consegues leituras de energia com os Shelly EM´s ou com o CT Clamp (transformador de intensidade-TI)

Tenta adicionar mais atributos nas Personalizações.

1- passo converter W em kWh usando o integration integration
2- passo usar a integraçao utility meter no source poe o sensor criado pelo integration integration
e já deve aparecer…

Tens que acrescentar uns atributos ao sensor, só que esses atributos não podem ser acrescentados nesses sensores porque são novos… Ele mudaram a maneira de definir sensores mas o integration parece ainda está da maneira antiga pelo que percebi e tens que dar uma martelada para definires esses atributos. Eu tenho o CT Clamp com um esphome e depois usei o integration.
Tenta acrescentar no final do config.yaml

homeassistant:
customize_glob:
sensor.*efergy_xxxxxxx*:
last_reset: ‘1970-01-01T00:00:00+00:00’
device_class: energy
state_class: measurement
unit_of_measurement: ‘kWh’

isto vai-te acrescentar os atributos a todas as entities com esse regex.

É necessário remover a integração feita pelo Hacs e adicionar os Shelly’s pela íntegraçao do Hassio.

Boas pessoal… A respeito deste tema, gostava de saber se alguém conseguiu fazer aparecer, nos devices do monitor de energia, os sensores de energia dos AC Daikin. Gostava de os adicionar aos meus devices mas não sei como os fazer aparecer lá.
desde já obrigado

Boa noite,

Peço desculpa mas estou mesmo “desperado”, ja tentei tudo…nao estou a conseguir colocar o meu sensor da efergy no Energy Management.
o que sera que estou fazer errado??

Desde ja o meu obrigado pela vossa ajuda.
Abraços

Olá.

Ontem estava com o mesmo problema.

O @dgomes sugeriu o seguinte:

precisas de ir à base de dados
e na tabela das statistics verificar que a unidade que lá está é mesmo kWh

Lá fui eu à base de dados.
Nos sensores que não me apareciam estava a unidade “Null”.
Substituir diretamente para KWh resolveu.

Qual base de dados? Desculpa a pergunta…nao sei mesmo que estas a referir…sou mesmo b***…loll
No meu sensors.yaml:

  - platform: efergy
    app_token:*************************
    utc_offset: UTC_OFFSET
    monitored_variables:
      - type: instant_readings
      - type: budget
      - type: cost
        period: day
        currency: Euro
      - type: amount
        period: day
      - type: current_values      

Onde esta o meu erro?

E com sensor pvout tb nao funciona:

image

mesmo assim zero…

Tb estou com o mesmo problema…

Não encontro os sensores que pretendo

Olá pessoal…

Há novidades sobre como adicionar os sensores, a este novo sistema?

Obrigado


Copyright © 2017-2021. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade