Dificuldade configuração Samba share

Boa noite a todos.

Neste momento estou com dificuldade em fazer com que o Samba share funcione corretamente ou o mesmo até pode estar a funcionar e eu não sei onde foi criada a pasta de partilha que devia gerar o mesmo com instalação do HA.
Neste momento estou a usar Linux versão Mint e nele instalei o virtualbox gerando uma máquina virtual com HA.
A realidade é que nunca trabahei com linux e nunca tinha tido contato com programas para criação de máquinas virtuais , foi por causa do interesse do HA que fui dar com estas possibilidades.
Tudo o que fiz foi seguindo tutoriais pois de outra forma não seria possivel e dai já andar a quase uma semana em pesquisa a tentar entender o que fiz mal no samba ou não esteja a ver bem.
E assim venho pedir ajuda se possivel da vossa parte.
Eu instalo o samba e faço as configurações criando apenas um username e password deixando a restante informação exatamente como esta,pois foi assim que vi a fazer.
O Samba arranca e fica operacional e com botao a verde depois vou a pasta de rede no linux mint e nada foi criado,penso que seria desta forma que deveria acontecer.
Pelo menos é desta forma que vejo acontecer mas todos os tutoriais que vejo são em Windows .

Desde de já peço desculpa pois penso que me expliquei bem mas da vossa parte pode não ser o suficiente.

Desde de já obrigado.

Eu penso que o problema reside nos ips algum tipo de conflito.
Pois estou a ver o log e no final aparece isto,nos ips onde tem xx aparece corretamente fui apenas eu que meti xx não vão pensar que é um erro.
Aparece o Ip atribuido a linux mint e o ip atribuido a maquina virtual do HA.

ould not find child 299 – ignoring
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_POOL_USAGE
Could not find child 301 – ignoring
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.

Desde de já obrigado.

O IP para aceder as pastas partilhadas do samba tem de ser o IP da maquina virtual do HA. No entanto para aceder terá de estar na mesma gama de IP. Depois é só colocar //IP_DO_HA, numa janela do explorador e deve conseguir!

Aqui vai uma configuração do meu samba:
Atenção que terás de mudar o IP para o IP da tua rede e não da maquina virtual do HA
O /16 a seguir ao ip tem a ver com a máscara de de rede. Podes mudar para estar de acordo com as tuas configurações de rede.


workgroup: WORKGROUP
username: o_teu_username
password: a_tua_pass
interface: ''
allow_hosts:
  - 192.168.1.0/16
veto_files:
  - ._*
  - .DS_Store
  - Thumbs.db
compatibility_mode: false

Boa noite Alberto Santos.
Desde de já obrigado pela ajuda ,vou tentar .
Obrigado

Boas Alberto.
Infelizmente nao estou a conseguir

workgroup: WORKGROUP
username: o_teu_username
password: a_tua_pass
interface: ‘’
allow_hosts:

  • 192.168.1.0/16 (aqui meti o meu ip do linux e não da maquina virtual seguido do /16 ).
    veto_files:
  • ._*
  • .DS_Store
  • Thumbs.db
    compatibility_mode: false
[/quote]

No log esta assim : 

daemon_ready: daemon 'smbd' finished starting up and ready to serve connections
waiting for connections
check_for_master_browser_fail: Forcing election on workgroup WORKGROUP subnet 172.17.0.1
check_for_master_browser_fail: Forcing election on workgroup WORKGROUP subnet 172.30.32.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.17.0.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.30.32.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.17.0.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.30.32.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.17.0.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.30.32.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.17.0.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.30.32.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.17.0.1
run_elections: >>> Won election for workgroup WORKGROUP on subnet 172.17.0.1 <<<
become_local_master_browser: Starting to become a master browser for workgroup WORKGROUP on subnet 172.17.0.1
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.30.32.1
run_elections: >>> Won election for workgroup WORKGROUP on subnet 172.30.32.1 <<<
become_local_master_browser: Starting to become a master browser for workgroup WORKGROUP on subnet 172.30.32.1
*****
Samba name server HOMEASSISTANT is now a local master browser for workgroup WORKGROUP on subnet 172.17.0.1
*****
*****
Samba name server HOMEASSISTANT is now a local master browser for workgroup WORKGROUP on subnet 172.30.32.1
*****
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_POOL_USAGE
Could not find child 298 -- ignoring
query_name_response: Multiple (2) responses received for a query on subnet 192.168.xx.xxx for name WORKGROUP<1d>.
This response was from IP 192.168.xx.xxx, reporting an IP address of 192.168.xx.xxx.

Vou ao chrome e meto pesquisa de //seguido do ip da maquina virtual  e gera o seguinte erro na pagina : 
Não foi possível acessar seu arquivoTalvez ele tenha sido movido, editado ou excluído.
ERR_FILE_NOT_FOUND.

Peço desculpa mas para muitos pode ser básico  mas para mim é mesmo dor de cabeça falta de conhecimento.

Muito obrigado.

Não coloca o ip da maquina, mas sim da rede, ou seja termina em zero Esse ip na configuração serve de controlo de acesso de outros pc na rede as pastas do HA.

Boa noite Alberto.

Desde de já obrigado pelo apoio e paciencia .
Então se bem entendi na configuração do Samba exeplo acima meto o ip da rede ,fiz command prompt num portatil que tenho e digitei ip config e penso que é o op que aparece a frente do IPv4 Address,correto?. Foi esse ip que inseri nas configurações do Samba.
fiz restart ao samba e pronto continua o problema,nada de pasta partilhada vou ao chrome e meto o ip do HA e nada.

Enfim Alberto penso que o problema será meu e não da máquina ,pois nao devo estar a fazer as coisas direito.
Acredito que se fosse em windows talvez conseguisse resolver pois os exemplos os tutoriais são muitos .

Mais uma vez obrigado

Queria aceder a pasta de raiz do HA por causa do HACS e assim não consigo ,fico de mãos atadas .
Aquela versão do windows que é só correr o comando era prefeita para mim : ) , mas como não tem supervisor estava limitado e decidi instalar numa máquina virtual e com base linux ,agora estou na mesma situação por causa do Samba ou da minha pessoa lol.

Não digita o IP da maquina mas sim da rede. Ou seja quando diigita o IP config o resultado em frente ao IPV4 é por exemplo: 192.168.1.55, retira o 55 e substitui por zero. Ou seja ficaria 192.168.1.0, que é o IP da rede. Colocaria o 192.168.1.0/16
Chamo atenção para o seguinte, verifique se os ip da maquina virtual do HA são da mesma familia da maquina onde está a tentar aceder. Ou seja se a maquina virtual do HA tem o IP 192.168.0.4 e a maquina de onde está a tentar aceder tem o IP 172.18.30.20 , quer dizer que as duas maquinas não estão na mesma rede. Aí terá de colocar, neste exemplo o IP 172.18.30.0, para conseguir aceder ao HA.
Chamo atenção para a configuração “domain”, se depois de colocar o IP que termina em zero não conseguir entrar verifique se a sua maquina está em algum domínio, qual o nome e coloque na configuração.

Pelo que li do seu log, a sua maquina virtual está com o IP 172.xxx.xxx.xxx, e a sua maquina virtual está com o IP 192.168.x.x, portanto vai colocar no IP o seguinte: 192.168.Y.0/16 e vai subtituir o Y, pelo valor que encontrar no IPV4, quando digitir IP config, na maquina de onde quer aceder. Que a partida terá um IP 192.168.Y.X. Depois não abre o chrome, abre o explorador de ficheiros e coloca:
\IP_DO_HA

Boa noite Alberto.

Mais uma vez obrigado pela ajuda e paciencia.

Bem tentei fazer aqquilo que me diz acima e quando pesquiso o ficheiro no sistema nada,estou mesmo a fazer algo mal provavelmente.

Obrigado.

Que ficheiro é que está a pesquisar? Não percebi!
Não vai desistir agora, pois não!? :grin:
Diga-me o que fez, para perceber onde está o problema.

1 Like

Boa tarde Alberto, desde de já obrigado pela força .

Não desisti fiz uma pausa ontem pois já andava a sonhar com o Samba lol.

Eu fiz o que pediu acima ,nas configurações do samba meti o ip da rede, quanto aos ips da máquina e Maquina virtual do HA começam por 192.168.xx.xxx.
Depois como disse acima abri o explorador de ficheiros do meu sistema linux e pesquisei \IP_DO_HA pois não entendi se isso era mesmo um atalho , depois como não resultou pesquisei pelo ip mesmo e depois por Home Assistant e Hassio tentando encontrar algo.

Abraço

Peço desculpa, enganei-me ao digitar, não é uma, são duas baras: \192.169.xx.xxx
E é para colocar no explorador de ficheiros, não no explorador da internet.
Se der erro, copie o logo do samaba e cole-o aqui.

Fomata o endereço como se fosse código, assim:

\\192.169.xx.xxx

vamos supor que o endereço da maquina virtual onde tem o homeassistant é 192.168.1.5, então abre o explorador do windows e coloca:

\\192.168.1.5

Depois carrega em enter
image

Se nada acontecer copie e cole aqui, o log do addon samba

Boa tarde,infelizmente não consigo.

Desde de já obrigado .

Verifico no log que o ip do homeassistant está como 172.30.32.1 e a rede que está a tentar aceder é 192.168.x.x. Isso requere outras configurações. Não consegue colocar o homeassistant na gama de ip 192.168.x.x?

Boa noite Alberto.

Náo sei o porquer de isso acontecer , pois eu tenho sistema mesh uso a aplicação da deco e quando vou ver os ip´s atribuidos tanto o pc instalado linux , virtualbox como a máquina virtual do HA estão todos com ip atribuido de 192.168.xx apenas mudando para cada um deles os 3 ultimos digitos do ip.
Por isso leva a crer que estaria correto.

Desde de já obrigado


Copyright © 2017-2021. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade