Atualizar HAss.io 0.100.3 para 0.103.0

Boa tarde a todos,
Durante esta semana tenho tentado varias vezes actualizar o Hassio e não consigo.
Fica a “mastigar” e depois do rebbot a versão continua a mesma.
Nos logs tenho esta informação:

19-12-13 10:00:50 WARNING (MainThread) [hassio.homeassistant] Don’t wait anymore of Home Assistant startup!
19-12-13 10:00:50 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!
19-12-13 10:00:50 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.100.3
19-12-13 10:00:50 INFO (SyncWorker_10) [hassio.docker.interface] Update image homeassistant/raspberrypi3-homeassistant:0.103.0 to homeassistant/raspberrypi3-homeassistant:0.100.3
19-12-13 10:00:50 INFO (SyncWorker_10) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.100.3.
19-12-13 10:00:51 INFO (SyncWorker_10) [hassio.docker.interface] Stop homeassistant application
19-12-13 10:00:54 INFO (SyncWorker_10) [hassio.docker.interface] Clean homeassistant application
19-12-13 10:00:56 INFO (SyncWorker_8) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.100.3
19-12-13 10:01:26 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
19-12-13 10:04:23 INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
19-12-13 10:06:07 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
19-12-13 10:06:12 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
19-12-13 10:06:12 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.100.3
19-12-13 10:06:12 INFO (SyncWorker_16) [hassio.docker.interface] Cleanup images: [‘homeassistant/raspberrypi3-homeassistant:0.103.0’]
19-12-13 11:37:58 INFO (SyncWorker_0) [hassio.docker.interface] Restart homeassistant/raspberrypi3-homeassistant
19-12-13 11:38:45 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
19-12-13 11:39:20 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
19-12-13 11:39:25 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
19-12-13 11:51:03 INFO (MainThread) [hassio.host.info] Update local host information
19-12-13 11:51:03 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/hostname1
19-12-13 11:51:04 INFO (MainThread) [hassio.host.services] Update service information
19-12-13 11:51:04 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ListUnits on /org/freedesktop/systemd1
19-12-13 11:51:05 INFO (MainThread) [hassio.host.network] Update local network DNS information
19-12-13 11:51:05 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/NetworkManager/DnsManager
19-12-13 12:04:23 INFO (MainThread) [hassio.store.git] Update add-on https://github.com/hassio-addons/repository repository
19-12-13 12:04:23 INFO (MainThread) [hassio.store.git] Update add-on https://github.com/home-assistant/hassio-addons repository
19-12-13 12:04:23 INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
19-12-13 12:04:26 INFO (MainThread) [hassio.store] Load add-ons from store: 62 all - 0 new - 0 remove
19-12-13 13:45:51 INFO (MainThread) [hassio.homeassistant] Updated Home Assistant API token
19-12-13 13:47:36 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.103.0
19-12-13 13:47:36 INFO (SyncWorker_10) [hassio.docker.interface] Update image homeassistant/raspberrypi3-homeassistant:0.100.3 to homeassistant/raspberrypi3-homeassistant:0.103.0
19-12-13 13:47:36 INFO (SyncWorker_10) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.103.0.
19-12-13 13:49:34 ERROR (MainThread) [hassio.utils] Can’t execute update while a task is in progress
19-12-13 13:53:27 INFO (SyncWorker_10) [hassio.docker.interface] Stop homeassistant application
19-12-13 13:53:44 INFO (SyncWorker_10) [hassio.docker.interface] Clean homeassistant application
19-12-13 13:53:46 INFO (SyncWorker_7) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.103.0
19-12-13 13:57:43 INFO (MainThread) [hassio.host.info] Update local host information
19-12-13 13:57:43 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/hostname1
19-12-13 13:57:44 INFO (MainThread) [hassio.host.services] Update service information
19-12-13 13:57:44 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ListUnits on /org/freedesktop/systemd1
19-12-13 13:57:45 INFO (MainThread) [hassio.host.network] Update local network DNS information
19-12-13 13:57:45 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/NetworkManager/DnsManager
19-12-13 14:03:49 WARNING (MainThread) [hassio.homeassistant] Don’t wait anymore of Home Assistant startup!
19-12-13 14:03:49 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!
19-12-13 14:03:49 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.100.3
19-12-13 14:03:49 INFO (SyncWorker_14) [hassio.docker.interface] Update image homeassistant/raspberrypi3-homeassistant:0.103.0 to homeassistant/raspberrypi3-homeassistant:0.100.3
19-12-13 14:03:49 INFO (SyncWorker_14) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.100.3.
19-12-13 14:03:51 INFO (SyncWorker_14) [hassio.docker.interface] Stop homeassistant application
19-12-13 14:03:59 INFO (SyncWorker_14) [hassio.docker.interface] Clean homeassistant application
19-12-13 14:04:01 INFO (SyncWorker_6) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.100.3
19-12-13 14:04:23 INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
19-12-13 14:04:31 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
19-12-13 14:09:12 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
19-12-13 14:09:17 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
19-12-13 14:09:17 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.100.3
19-12-13 14:09:17 INFO (SyncWorker_11) [hassio.docker.interface] Cleanup images: [‘homeassistant/raspberrypi3-homeassistant:0.103.0’]

Conseguem dizer-me o que pode estar a passar e como resolver?
Obrigado
Abraço

@pmdsaude quando publicares código ou logs deves sublinhar o texto que queres transformar em código e clicar no ícone </>. Deverá existir um espaço antes e outro depois do bloco de código para que funcione correctamente. O código em Yaml é muito sensível aos espaçamentos e sem o código devidamente formatado não te poderemos ajudar. E nos logs há pormenores que só devidamente formatados se conseguem ver.

Vê um exemplo:

Em relação a esse problema, faz uma pesquisa aqui no fórum pois esse é um problema comum e que já foi falado e resolvido.

ahahah a mim, também me aconteceu algo, depois do update que fiz ontem… :frowning:

o problema pode nao ser o mesmo, mas aconteceu qualquer coisa de errado

Setup failed for automation: Could not set up all dependencies.
10:10 AM setup.py (ERROR)
Unable to set up dependencies of automation. Setup failed for dependencies: group
10:10 AM setup.py (ERROR)
Setup failed for switch: Could not set up all dependencies.
10:10 AM setup.py (ERROR)
Unable to set up dependencies of switch. Setup failed for dependencies: group
10:10 AM setup.py (ERROR)
Setup failed for script: Could not set up all dependencies.
10:10 AM setup.py (ERROR)
Unable to set up dependencies of script. Setup failed for dependencies: group
10:10 AM setup.py (ERROR)
Setup failed for light: Could not set up all dependencies.
10:10 AM setup.py (ERROR)
Unable to set up dependencies of light. Setup failed for dependencies: group
10:10 AM setup.py (ERROR)
Setup failed for device_tracker: Could not set up all dependencies.
10:10 AM setup.py (ERROR)

mais uma coisa para partir a cabeça

@David_Fialho foi o update de que versão para que versão? Quando puderes coloca aqui o teu configuration.yaml (devidamente limpo de dados pessoais) para confirmar se o problema será o mesmo.

Jorge, desculpa, está resolvido. é o que dá ter uma filha de 7 meses ao colo com um portátil à frente, e ao mesmo tempo, a tentar implementar o sistema de rega aqui em casa… yaml é muito sensível aos espaços e aos -

:grin:

O yaml não perdoa nada de facto e a indentação dos espaços normalmente é o que dá mais problemas. Mas o que interessa é que está resolvido!

Olá @j_assuncao, depois de alguma procura não encontro nada aqui no forum que me ajude na minha situação. Se me puderes indicar o tópico eu agradecia-te.
A situação é estranha, até ao momento nunca tipve problemas em actualizar o HASS.IO esta é a única em que estou a ter esta dificuldade.
Obrigado pela ajuda.

O problema tem a ver com a api_password já não ser usada. Há pelo menos uma publicação feita pelo @sslopes sobre isso.

1 Like

Obrigado Jorge,
Mais fácil do que parecia, para quem sabe…
Tive apenas de apagar no configuration.yaml a linha que tinha api_password.

Obrigado

1 Like

Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade