Ajuda com erro sobre telegram

Boa noite malta. Ultimamente tenho este erro no log do HA.

2019-05-18 22:59:10 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:10 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:11 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:11 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:14 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:17 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:20 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:21 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:22 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:23 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:25 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:26 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:29 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:30 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:31 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:31 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:35 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:38 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:42 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:43 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:44 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:44 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:48 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:48 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:48 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:51 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:52 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:53 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:53 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:54 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:55 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:58 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:59 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)
2019-05-18 22:59:59 ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)

Será que alguém me consegue dizer como corrigir este erro?
Muito obrigado pela atenção

Esse erro acontece por tens mais do que uma instância do bot a correr. É um erro normal se usares o Telegram no HA e no NR em simultâneo.

1 Like

Por acaso uso nos yaml que quero as notificações. Se calhar o melhor é meter uma única no configuration.yaml… Hihihihihihi :sweat_smile:
Obrigado pela dica.

Boa tarde, estou com esse erro ao tentar enviar uma imagem capturada da minha câmera.

Error sending file: urllib3 HTTPError (‘Connection aborted.’, timeout(‘The write operation timed out’)). Args: (822662086, <_io.BufferedReader name=’/config/www/imgs/cameras/camera.frente1_20191008-1449.jpg’>), kwargs: {‘caption’: ‘Foto da frente.’, ‘parse_mode’: ‘Markdown’, ‘disable_notification’: False, ‘disable_web_page_preview’: None, ‘reply_to_message_id’: None, ‘reply_markup’: None, ‘timeout’: None}

Que código estás a usar na automação?

1 Like

Desculpe-me na demora do retorno,

Um amigo deu a sugestão de reduzir o caminho onde as imagens ficam gravadas, então mudei o path para /config/www/camera/ aí funcionou maravilha. Obrigado!!

1 Like

Rodolfo sabe se tem alguma solução para esse erro do post?

ERROR (updater) [telegram.ext.updater] Error while getting Updates: Conflict: terminated by other getUpdates request; make sure that only one bot instance is running (409)

Sei que é por ter o bot no config.yaml e no Node-Red ao mesmo tempo, mas eu queria ter os dois n é possível? Tenho que escolher apenas um?

Sim apenas um, não faz sentido teres dois.

É que eu não sei mexer muito no node-red, por exemplo fiz a polly dizer o que eu escrevo em meu bot no telegram, porem n sei fazer para receber uma notificação de status no meu telegram usando o node-red ai eu uso o do config.yaml entende?

Se não entendes de NR faz apenas em yaml… porque usas os dois ? Não estou a entender.


Copyright © 2017-2020. Todos os direitos reservados
CPHA.pt - info@cpha.pt


FAQ | Termos de Serviço/Regras | Política de Privacidade