# MQTT quase que funciona

**URL:** <https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709>\
**Category:** Configuração\
**Tags:** hassio, tasmota\
**Created:** [19 Abril , 2021 13:07 UTC](https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709 "2021-04-19T13:07:15Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![johnytalker](https://forum.cpha.pt/letter_avatar_proxy/v4/letter/j/dec6dc/32.png) [@johnytalker](https://forum.cpha.pt/u/johnytalker)\
**Post date:** [19 Abril , 2021 13:07 UTC](https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709/1 "2021-04-19T13:07:15Z")

</div>

Bom, reposto que está o sistema, tenho de voltar ao problema inicial, o MQTT.

Instalo o addon do broker sem qq problema e mete-o a correr. Vejo o log e perfeito sem qualquer erro.

Depois instalo a integração que aparece automaticamente e quando reinicio o HA no log do add-on tenho um erro a dizer «ERROR: Can’t setup Home Assistant service mqtt» .

Tento de novo criando um utilizador especifico para o mqtt. Desinstá-lo a integração e volto a instalar com este novo utilizador e a mesma mensagem de erro. Estou a resumir pois já fiz este processo algumas 50 vezes com todas as variantes possíveis. Estou a ficar seco de ideias, daí recorrer a vós.

De referir ainda que se for à integração e fizer escutar aparecem-me os cliente todos, todos são visíveis, não passam é para entidades do home assistant.

Por fim, pois já me estou a esticar, aparece-me o seguinte erro no log do sistema que julgo poder estar na origem do problema : «21-04-19 12:44:51 ERROR (MainThread) [supervisor.api.ingress] Ingress error: 400, message=‘Invalid response status’, url=URL(‘[http://172.30.33.0:8099/socket.io/?EIO=4&transport=websocket&sid=pkh6DOOd6CN5Te63AAAi](http://172.30.33.0:8099/socket.io/?EIO=4&transport=websocket&sid=pkh6DOOd6CN5Te63AAAi)’) » .

Obrigado,

---

<div class="post-metadata">

**Author:** ![RodolfoVieira](https://forum.cpha.pt/user_avatar/forum.cpha.pt/rodolfovieira/32/14633_2.png) [@RodolfoVieira](https://forum.cpha.pt/u/RodolfoVieira)\
**Post date:** [19 Abril , 2021 13:57 UTC](https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709/2 "2021-04-19T13:57:46Z")

</div>

Duas questões.  
Tens alguma linha mqtt: nos teus ficheiros yaml?

Podes colocar um print da tua configuração do addon mqtt?

---

<div class="post-metadata">

**Author:** ![johnytalker](https://forum.cpha.pt/letter_avatar_proxy/v4/letter/j/dec6dc/32.png) [@johnytalker](https://forum.cpha.pt/u/johnytalker)\
**Post date:** [19 Abril , 2021 14:18 UTC](https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709/3 "2021-04-19T14:18:13Z")

</div>

Rodolfo,

Presentemente no configuration.yaml já não tenho nada, pois das pesquisas que fiz ao que parece já não é preciso.

Mas como forma de despiste meti o que vem por defeito na documentação , ou seja:  
mqtt:  
broker: 192.168.1.92

isto tinha como resultado o broker aparecer com este IP em vez do 127.xxx.xxx.xxx mas também não funcionava, ou seja não me criava as entidades na integração. Apesar de, como já referi , se as escutar ouço-as.

---

<div class="post-metadata">

**Author:** ![RodolfoVieira](https://forum.cpha.pt/user_avatar/forum.cpha.pt/rodolfovieira/32/14633_2.png) [@RodolfoVieira](https://forum.cpha.pt/u/RodolfoVieira)\
**Post date:** [19 Abril , 2021 14:43 UTC](https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709/4 "2021-04-19T14:43:03Z")

</div>

Aparece no nosso servidor de discord para debatermos isso e depois voltas aqui com a solução.

---

<div class="post-metadata">

**Author:** ![johnytalker](https://forum.cpha.pt/letter_avatar_proxy/v4/letter/j/dec6dc/32.png) [@johnytalker](https://forum.cpha.pt/u/johnytalker)\
**Post date:** [19 Abril , 2021 15:27 UTC](https://forum.cpha.pt/t/mqtt-quase-que-funciona/7709/5 "2021-04-19T15:27:45Z")

</div>

Graças ao Rodolfo e mais uns amigos, tenho o meu problema resolvido. No meu caso a solução estava em fazer um upgrade à versão do Tasmota, que tinha nos devices, de 9.2 para 9.3.1 . Após isso bastou enviar o comando SO19 1 , na consola do Tasmota e de imediato os devices começaram a aparecer na integração do MQTT.

Mais uma vez obrigado a todos.
